It's all about the answers!

Ask a question

Since the build tools were upgraded to CLM 6.0.1 SCM Tools we have been facing issues with Fetch operation failing with JAVA HEAP Space messages

Samir Patel (357) | asked Apr 21 '16, 5:10 p.m.
After the upgrade we have noticed that some of the existing definitions and most of the new definition created are failing on Fetch operation with below message.

2016-04-18 20:32:55 [Jazz build engine] Fetching files to fetch destination "<FETCH_PATH>" ... java.lang.OutOfMemoryError: Java heap space
    at ?

There has been no change in source that is being fetched other than normal updates for new versions of files being updated. Some of the Definitions were copied from already existing definitions, while others were created from scrach.

For some of the new definitions we have updated JVM args with -XX:MaxPermSize=2048m on ANT tab of the build definition and that seems to have resolved it for some. However, there number of other definitions that continue to either fail on Fetch operations or get hung even after updating the JVM property.

Has anyone else seen this behavior? If you have, please share what else you have been able to do to resolve the issue?


One answer

permanent link
Don Yang (7.7k21108138) | answered Apr 21 '16, 8:45 p.m.
Hi, Samir

It doesn't seem to be Ant related OOM but JBE has got it. Therefore, you may want to add/increase heap size for JBE by going to /buildengine/eclipse/jbe.ini and add -Xmx1024m under -Vmargs(if there is a value there, you may increase to higher heap size).(you can restore ant JVM to default and see what happens)

Samir Patel commented Apr 21 '16, 9:12 p.m.


Thanks for the response. I will try your suggestion. However, what I am baffled about is that same change worked for another definition with same message. So the mystery still remains as to why it worked their and not with other.

Don Yang commented Apr 21 '16, 9:43 p.m.

I am not sure if it is coincident or ant JVM does help in some definitions. The error message does point to JBE related problem.

Samir Patel commented Apr 24 '16, 4:20 p.m.

I have updated both the JVM arg as well as jbe.ini and result still show JAVA HEAP SPACE issue. I am in process of increasing the VMarg to 2048. One more observation noticed is that this seems to be an issue with only new definitions. Already existing definition with same code base seem to work fine without any modifications to the build definitions' JVM arguments or to the jbe.ini.

Your answer

Register or to post your answer.