It's all about the answers!

Ask a question

RTC - Git integration - error 22 on push


john norris (20733844) | asked Apr 17 '16, 4:07 a.m.
edited Jul 14 '16, 9:45 a.m. by Ralph Schoon (63.1k33646)

Hi,

I continue to follow the tutorial https://jazz.net/wiki/bin/view/Main/RTCGitIntegrationSetupUsingNode.

I have started the node.js server - "nodejs main.js" using v5.10.1. Using RTC 6.0.1.

Got to the step where I cloned the repo from the 8888 port (node.js), made some changes, committed locally with "task 2" in the message and then pushed.

C:\GitWork\groovyTest>git push origin master
error: Cannot access URL http://mint-rtc:8888/git/groovyTest.git/, return code 22
fatal: git-http-push failed

There is no output from node.js - I have run it with nohup and nothing new in nohup.out, nor if I just run it on the command line with open terminal.

Just to add, git remote -v gives
origin  http://mint-rtc:8888/git/groovyTest.git (fetch)
origin  http://mint-rtc:8888/git/groovyTest.git (push)

but if I do the url in a browser then I do get a login dialog as in the tutorial

Also, if I push via RTC client (eclipse) then I am asked for http authentication and then get

Can't connect to any URI (the mint-rtc above) 302 Found.

I am using a developer user rather than the gituser that I added to the server authentication details. Is that going to cause a problem?

Also when I coned the git rep I was not asked for a user

C:\Temp>git clone http://mint-rtc:8888/git/groovyTest.git
Cloning into 'groovyTest'...
warning: You appear to have cloned an empty repository.
Checking connectivity... done.

Any ideas where I am going wrong?

Regards,

John


Comments
john norris commented Apr 17 '16, 4:59 a.m. | edited Apr 17 '16, 5:07 a.m.

x


john norris commented Apr 17 '16, 5:04 a.m. | edited Apr 17 '16, 5:07 a.m.

z

2 answers



permanent link
Shubjit Naik (1.5k1613) | answered Jul 14 '16, 10:31 a.m.
edited Jul 14 '16, 12:16 p.m.
  Hi All

We identified the error code 22 is seen when BASIC registry (CCM URL) for authentication is used in config.json with the default authentication settings in JTS/RTC. It works well when Nodejs server is configured against LDAP server.

By Default a JTS server is not enabled for HTTP Basic authentication and uses FORM based Authentication. You would need to edit the web.xml files of JTS/CCM and enable BASIC <auth-method> for it to work.

Or you could connect Nodejs , through config.json to the LDAP server that your CLM is connected to. 

Comments
john norris commented Jul 14 '16, 10:59 a.m.
Hi Shubjit,
I checked the jazz tutorial that I used (see first entry) and that uses BASIC authentication. So for the person who wrote that, BASIC does work with nodejs.
So if you are correct and it simply can't work, how did the tutorial work for the author?
 

Shubjit Naik commented Jul 14 '16, 12:15 p.m.

Hi John

It does work with a few modifications in JTS/RTC configurations. Or if CLM is connecting to an Enterprise Directory (LDAP), you could connect Nodejs to the same Enterprise directory instead of changing JTS/RTC to basic authentication.

Let me re-direct to our online documentation , Configuring Auth for Nodejs Server

Step 2c, "If your Jazz Team Server is configured to use HTTP Basic authentication, you can use the same server."

By default JTS is not configured with Basic Authentication, and we would need to change to Basic by editing the web.xml under  <jts/ccm_war_extract>\WEB-INF directory


permanent link
Christian Schlag (111) | answered Jul 14 '16, 9:16 a.m.
 Hi Jon,

I get the same issue. Did found a solution?

What happens, when you open the git repo url in your browser?

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.