It's all about the answers!

Ask a question

Error: The processing instruction target matching "[xX][mM][lL]" is not allowed

Ranjan Kumar (11134) | asked Mar 25 '16, 7:37 a.m.
    I am trying to change the Operation Behavior (Source Control: Deliver (client)) and I get this error for any change I try to make at any level:
             The processing instruction target matching "[xX][mM][lL]" is not allowed.
I have all the permission I need to make these changes. The error detail shows this message:
             The operation is not governed by process.

I am using Eclipse Jee Mars with Rational Team Concert Version: 6.0 plugin.



Ranjan Kumar commented Mar 25 '16, 7:40 a.m.

Looks like the image file was not attached properly. Trying to attach again.

Abraham Sweiss commented Mar 25 '16, 9:03 a.m.
  1. Has the latest iFix been applied to both the client and server?
  2. I take it the server is also 6.0
  3. Please provide step by step instructions on how to recreate.

Ranjan Kumar commented Mar 25 '16, 10:27 a.m.

Thanks Abraham for looking at the issue. Here are the details.
1. Client version: Rational Team Concert 6.0, Build id: RTC-I20150519-1214

2. Server version:
- Change and Configuration Management - Core Libraries 6.0.1 RTC-I20151109-2045 iFix001
- Jazz Foundation - Core Libraries 6.0.1 RJF-I20151106-1823 iFix001

3. Steps to reproduce:
- Using Eclipse client open the Project Area and go to "Process Configuration" tab.
- Team Configuration -> Operation Behavior (unconfigured)
- Click on cell "Source Control: deliver (client)" for Everyone
- Select  "Preconditions and follow-up actions are configured for this operation"
- Add (any) precondition. For example, "Prohibit Workspace Errors"
- Save the project => error: The processing instruction target matching "[xX][mM][lL]" is not allowed


Abraham Sweiss commented Mar 25 '16, 12:56 p.m.

I was not able to recreate.
Server = 6.0 iFix2a
Client = 6.0  - I used eclipse 4.2.x that we bundle with the RTC client
used out of the box scrum template.

Are you using the eclipse client that we bundle or an existing eclipse client.  If the latter please confirm if the issue can be recreated with the bundled version of eclipse.

Ranjan Kumar commented Mar 25 '16, 1:38 p.m.

I am using existing Eclipse Client (Jee Mars) with RTC plugin.
I just tried RTC with bundled Eclipse and it is working fine there.
With existing eclipse client, "Team Configuration -> Operation Behavior" is shown as "(unconfigured)" while in RTC  with bundled eclipse, it shows just as "Operation Behavior" and I was able to modify the precondition and save it.

I can continue to use this as a workaround.

Thanks for your help.

Accepted answer

permanent link
Abraham Sweiss (2.4k1331) | answered Mar 25 '16, 1:44 p.m.
Glad to hear things are working now. 

There were unexpected results when using pre-existing MARS eclipse client.  Once the eclipse client that is bundled with the RTC plugin was used, everything worked as expected.

Ralph Schoon selected this answer as the correct answer

2 other answers

permanent link
Nikola Vanevski (1) | answered Oct 30 '16, 7:41 a.m.

I am running into the same issue with every Eclipse client (from Juno to Neon) on 6.0.2 (client under MacOSX, server under RedHat Linux 6.7). The issue appears if the Eclipse is started with JDK 8 - but not under JDK 7. It seems that the problem is with XML parsing (the process configuration XML is not even read properly, and notice the duplicated "process-specification" tag that appears after a change in the process

<?xml version="1.0" encoding="UTF-8"?>

<process-specification xmlns="">




<?xml version="1.0" encoding="UTF-8"?>

<process-specification xmlns="">


    <role-definition cardinality="single" description="The person responsible for managing the Product Backlog." name="Product Owner" role-id="Product Owner"/>

    <role-definition cardinality="single" description="The person responsible for the process." name="Scrum Master" role-id="ScrumMaster"/>

    <role-definition cardinality="many" description="A member of the cross-functional team." name="Team Member" role-id="Team Member"/>

    <role-definition cardinality="many" description="The stake holder." name="Stakeholder" role-id="Stakeholder"/>



Workaround is to set the eclipse.ini "-vm" argument to point to JDK 7, but this disables some features and libraries that we need.

Is there any pointer why this happens under JDK8, and is any fix expected?



permanent link
hani zaidi (1125) | answered Aug 15 '16, 7:51 a.m.

I was able to reproduce this problem when trying to "Save All" from RTC main tab after changes in Team Configuration -> Permissions. Saving the changes from Project Area window instead resolved the issue. I am using existing Eclipse Client (Luna) with RTC plugin.


Ralph Schoon commented Aug 15 '16, 8:04 a.m.

It is totally unclear if these are related. Please open a PMR or work item if you want this to be addressed.

Your answer

Register or to post your answer.