It's all about the answers!

Ask a question

why no option as "work with git" under source control?

jane zhou (106968) | asked Mar 09 '16, 12:37 a.m.

   My RTC version is 6.02M2.

  I tried to register a git repo according to procedure as follows, and I have permission of JazzProjectAdmins and JazzAdmins.
  But under CCM project page, when click source control, I did not find option "work with git"

  I only can find 3 options  : Attribute Definition /New Workspace Configuration/ Sandbox Subfolder

  So I am wondering what should I do to make "Work with git option" appear?  Any precondition I need to satisfy besides group? Thanks!

  Procedure to register a git repo:

2 answers

permanent link
Geoffrey Clemm (30.1k33035) | answered Mar 09 '16, 6:13 p.m.
It sounds like you are looking in the Application Administration page for a CCM project area ... that is not where you find the "work with git" page.
Open some CCM project area (as if you are just an end user).
Along the top of the page, you should see the drop-down menus for: Project Dashboards, Work Items, Plans, Source Control, Builds, and Reports.
Click on "Source Control", and you should see the "Work with GIT" menu item ... click on that and you will get the "Work with GIT" page.

permanent link
Rohit Balduwa (945511) | answered Mar 09 '16, 1:07 a.m.
Hi Jane

CLM6.0.2 is not released yet for general availability and under development. There can be features that are under testing and will be worked upon.

From development knowledge center( under progress), i see the below details, so the 'Work with Git' option exists.
Registering Git repositories:

Also, i see below note:
Note: The Git-related menu options in the web client are enabled by default. You can disable the menu options by setting RTC_HIDE_GIT_MENU_OPTIONS or by setting the Java property on the Jazz Team Server (Requires server re-start).

I have not tested for CLM6.0.2 yet. But verify the above options.

If this answers your question please mark it as accepted.


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.