It's all about the answers!

Ask a question

try to use WorkItemAPIs For OSLCCM20 but can not find :/jazz, how to fix it?

jane zhou (1061068) | asked Mar 08 '16, 5:38 a.m.
 Hi All,
      My RTC version is 6.0.2 M2.
       I tried to access https://<server>:<port>/jazz/rootservices,  but I got response as "Context Root Not Found"
      Then I tried https://<server>:<port>/jts/rootservices and https://<server>:<port>/ccm/rootservices, both can trigger downloading a file.
       And I opened the files downloaded, I search for " ServiceProviderCatalog  " as mentioned as the following instruction for WorkItemAPIs For OSLCCM20 , but I did not find it. 

       And I have checked https://<server>:<port>/jts/admin, under Application Administration, I did not find any item related to /jazz there.

       So I am wondering whether I need to install something or enable something to make /jazz folder accessible?

how to use Work item service provider
  1.  The root document is exposed at  https://<server>:<port>/<app>/rootservices . In a typical RTC testbed, this is  https://localhost:9443/jazz/rootservices
  2. Fetch this document and extract the Change Management Catalog URL (pointed to by  rdf:about ) of the element  oslc:ServiceProviderCatalog  in
          <oslc:ServiceProviderCatalog rdf:about="https://localhost:9443/jazz/oslc/workitems/catalog">
             <oslc:domain rdf:resource=""/>
Best Regards,

One answer

permanent link
Shawn Maclaga (1963) | answered Mar 08 '16, 9:06 a.m.
I believe the default context root changed from /jazz to /ccm in 3.x.
For users using 2.x or newer versions that were upgrades from 2.x, the context root will be/jazz.
For new installations of 3.x or higher, the default should be /ccm

For reference on finding the ServiceProviderCatalog, have a look at
(note that still has the /jazz context root):

In the rootservices, you should see a section:
  <oslc:ServiceProviderCatalog rdf:about="">
    <oslc:domain rdf:resource=""/>

I believe this is the section you're looking for on your server.


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.