It's all about the answers!

Ask a question

Required Approval not working correctly - cannot select type of approval


nannette Mori (50880) | asked Oct 15 '15, 10:26 a.m.

I added a precondition for required approvals for a Work Item.

When I pick the approval type and then I add the approver it does not give me a drop down to update the approval to approved.  The only option is "pending"  Is there something else I need to set somewhere?

Accepted answer


permanent link
nannette Mori (50880) | answered Oct 16 '15, 9:59 a.m.
I don't think I explained this correctly.  I could not select approve, rejected to move it from pending, but we found the problem was that for some reason there duplicate user entries for me and once I deleted those duplicate entries the approval functionality worked. 
Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Ralph Schoon (63.2k33646) | answered Oct 15 '15, 10:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Oct 15 '15, 10:32 a.m.
You can not create an approved approval.  (What would it mean in any case, if you could?)
You can only create an approval which is pending.
You then add the approvers.
Once the approvers approve, the cumulative state of the approval is calculated from the approvers verdicts.
It is only approved, if all approvers approved.

This works as designed.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.