It's all about the answers!

Ask a question

Excelmporter: Unable to import Test Environment to Test Plan's test environment section


Don Yang (7.5k2195130) | asked Sep 16 '15, 4:53 a.m.
edited Sep 16 '15, 4:55 a.m.
In RQM/RQMExcelImporter 5.0.2, I tried sample: Testplan_Testcase_Testscript_TER_Environment_Iteration_AllInOne.cfg/Testplan_Testcase_Testscript_TER_Environment_Iteration_AllInOne.xls,
in cfg file, it has
===
// this configuration file will create a configuration object for each one listed
configuration.XLSStartRow=2
configuration.dc:title=A
configuration.description=B & "<br/> OS:" & C & "<br/> Memory:" & D
configuration.XLSWorksheetID="Configuration"
configuration.XLSArtifactID=E

//Config for Testplan
testplan.dc:title=C1
testplan.XLSArtifactID=C1
testplan.Section("myns:com.ibm.rqm.planning.editor.section.planBusinessObjectives","RQM-KEY-TP-BUSS-OBJ-TITLE")=Div(C2)
testplan.Section("myns:com.ibm.rqm.planning.editor.section.planTestObjectives","RQM-KEY-TP-TEST-OBJ-TITLE")=Div(C3)
testplan.Section("com.ibm.rqm.planning.editor.section.planTestEnvDetails","RQM-KEY-TP-TEST-ENV-DETAIL-TITLE")=Div(C4)
testplan.XLSLink=testcase
testplan.configuration=Link(H3)
testplan.XLSWorksheetID="Testplan" : "Test"
testplan.jzalm:owner="abc"
==
My understanding is that it will create 3 test environments and add them to newly created testplan's test environment section.

However, the import does not have any error and it only created 3 test environments in Test Environment view.
I don't see Test Environment section in Test Plan has anything.

Shouldn't the below lines in cfg suggesting it will add the new test environments to Test Plan's [Test Environment] section:

testplan.Section("com.ibm.rqm.planning.editor.section.planTestEnvDetails","RQM-KEY-TP-TEST-ENV-DETAIL-TITLE")=Div(C4)

"com.ibm.rqm.planning.editor.section.planTestEnvDetails","RQM-KEY-TP-TEST-ENV-DETAIL-TITLE")=Div(C4)
testplan.configuration=Link(H3)

If that is the case, what is wrong with the result as I don't see any error during import?

Another question is that if there is any way in ExcelImporter to import the Environment Option under test plan > test
environment section > platform tab?



Thanks

One answer



permanent link
William Chen (31215) | answered Sep 16 '15, 9:53 a.m.
Hi Don - The config file works fine in 4.0.6 but we need to find out what has changed in 5.0.2.



Comments
William Chen commented Sep 16 '15, 10:11 a.m.

5.0.2 works fine for me as well. Please check your process roles and permissions: Save Test Environment & XML Import.


Don Yang commented Sep 16 '15, 8:30 p.m.

Hi, William

Thank you very much for the test result. I was expecting to see the entries in Test Environment section instead of Software Test Environment Details section.
Yes, it is there in Software Test Environment Details section after importing in v5.0.2.
I am confusing with this result now.

In Lab Management > Test Environment view, I can see the three Test Environments created there. That means Configuration.xxx in cfg are intended to create Test Environment and "testplan.configuration=Link(H3) " is to link TestPlan's TestEnvironment. But why it goes to Software Test Environment Details section?

is it possible to get anything to Test Environment section instead? Thanks



1
Ian Wark commented Sep 17 '15, 1:05 a.m.

I am using RTC 4.0.7 iFix004 with MS Office 2013 64bit with the 4.0.7 Excel Importer.
We are able to see the Test Environments imported into the Big_Plan, so perhaps this is a problem in RTC 5.0.2. See the screen capture in the below link. But we have the same issue with not knowing how to import new Platform Coverage for those Test Environments. I have asked the question about environment options here: Can you import environment options into a test plan?


William Chen commented Sep 17 '15, 12:27 p.m.

Hi Don,

You should see all three Test Environments by clicking on the plus sign or add button from Test Plan -> Test Environments -> Test Environment tab:


The config file is working correctly based on Software Test Environment Details implementation:

id: com.ibm.rqm.planning.editor.section.planTestEnvDetails
extensionDisplayName: RQM-KEY-TP-TEST-ENV-DETAIL-TITLE

To fix your issue, you could use POST command to add those new Test Environments into Test Environment section.

Hope this helps!

Will


Don Yang commented Sep 18 '15, 1:11 a.m.

Thanks Will

I can see the test environments from the + only.
I don't know why Ian can get the result directly into Test Environment tab in v4.0.7. Maybe I need to check with v4.x as well.

Thanks

Your answer


Register or to post your answer.