It's all about the answers!

Ask a question

not able to build the application

Jarugula SureshChandra (1111) | asked Sep 03 '15, 7:59 a.m.
edited Apr 22 '16, 2:07 a.m. by Ralph Schoon (63.2k33646)
 Hi All,

While i am trying to build the application from eclipse getting following error.

You cannot request a build for "<<>Build Definition ID >" because its supporting build engines do not have request processing enabled.

Please help how can i trouble shoot the issue.

jsc01856 ,

2 answers

permanent link
Rick Patterson (4048) | answered Apr 21 '16, 3:52 p.m.
Hi.   We just had this happen to us with a Hudson/Jenkins type of RTC build engine.  We had changed the Jenkins server in an existing build engine to refer to a new Jenkins machine //jenkins2 instead of //jenkins1.  I had updated the RTC Build Engine to change the https address of the Jenkins server, and tested the connection (and it was fine, and done with authentication), and the connection itself worked.   Builds instated from Jenkins worked fine.   But, if we did a right-click in the RTC client of a build definition that used this now updated build engine pointing to the now Jenkins server, we would get the error reported here.    If we expanded Build options in the build definition, and manually selected the build engine (even though it was the only build engine named in the build definition), then it would work without this error.

To get around this, we ended up having to create a new  build engine pointing to the to the same Jenkins server, and then manually going through 50 or 60 build definitions, and switching the supporting build engine to the new one, and removing the old one.  The the Request Build would work without his error.

permanent link
Spencer Murata (2.3k115971) | answered Sep 03 '15, 9:30 a.m.
There are three things you need to make sure are set for your engine to have it process requests.  I am assuming this is a Jazz Build Engine, but you need to make sure that the engine is active, it is supporting the right build definitions, and it has request processing enabled (if JBE). Build Request Requirements

Jarugula SureshChandra commented Sep 04 '15, 2:16 a.m.

Hi Murata,

Thanks for your reply, below or the thing upon your suggestion.
Yes, it is Jazz Build Engine.
Yes, It's already in active.
Yes, it's supporting the right build definition.
If  i am check the build engine process pools for request and Monitor the last contact time and parse the Threshold value.
After that i can see warning That, The build engine process represented by this engine does not appear to be processing requests. The process has never contacted the repository. You should check that the build engine process is running on the build machine. You can adjust build engine monitoring in the build engine editor. 
i don't know what i did mistake here. i am new for this, please guide me how i can fix this.

Suresh J

Spencer Murata commented Sep 04 '15, 8:54 a.m.

What does the Jazz Build Engine log show?  Do you see that it connects to the repository?


Jarugula SureshChandra commented Sep 08 '15, 8:33 a.m.

Hi murata,

Yes i can see the repository connection successfully. but where i can find the log. i am trying to build the application via remotely.
Please share me if you any video tutorial link .

Zeeshan Choudhry commented Sep 08 '15, 9:24 a.m.

 Start JBE with -verbose option on your build machine and share the output. 

jbe -repository https://host:port/ccm -userId myuser -pass mypass -engineId myengine -verbose 

The build machine must be able to contact the RTC server machine and vice versa. 
so also do a ping test from RTC server machine to the build machine and the other way around. 

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.