It's all about the answers!

Ask a question

Issues with RTC 5.0.2 to 6.0 upgrade on IBMi

Melissa Weaver (621215) | asked Aug 21 '15, 2:55 p.m.
edited Aug 25 '15, 4:21 p.m.

I did an upgrade from RTC 5.0.2 to 6.0 and encountered the following issues.  We run everything on the IBMi  (V7R2).  I used the interactive upgrade guide.

* The DB2 pre-instructions did not work   -verify  would not run.  The RUNSTATS  is not applicable on IBMi.  The files listed to be checked did not exist in the JAZZ* libraries/schemas.  This step also did not have appropriate help links, as none of the links were for IBMi.

                           Action:  skipped this step

 * None of the RTC502 files (ie. /QIBM/ProdData/JazzTeamServer60/server/conf/jts,  ccm, qm, rm) had the public URL line in them. The RM  file was also missing JTS URL. This caused the upgrade scripts to fail.    ADDLICPGM for RTC502 apparently did not add those lines as expected.

                           Action:  added public URL, and JTS URL to files and restarted 

* Restarting the upgrade scripts failed due to locks.

                        Action:  ran the QSH command  ./ –resetRepoLockId  each time for the respective                       application ( ccm, jts, rq, rm) before rerunning script.   

*     * We have QM and RM installed though we have not used.  The QM and RM upgrade steps failed for no apparent reason (based on the logs). 

                         Action:  reran upgrade script.   Appeared to complete successfully the second time. 

* Ran the Websphere upgrade with the incorrect product names.  The script ran without apparent errors.  However it did not complete correctly - we later found the errors buried in the logs.  After much research determined problem and reran script. Though the rerun was not clean, and we still had issues to resolve

Question:  Should the script have failed if the 502 applications did not exist?  This would have let me know there was a problem with the names.

Suggestion:  We used ccm  as the JazzAppName name, when it expected ccm.war.  An example would have been helpful.   An example of how to enter the maximum heap size would have also been helpful (did we need units, or just the numbers?).

      *  * Verify Upgrade Steps:  The 60 files did not have the public URLs in them.  Even though the 502 files had been updated to contain them prior to the upgrade.  The publicURLs are not added to the files during a standard RTC6.0 install either (checked this on a clean install on another server)

                           Action:  add public URLs to all files.

Has anyone else had any similar issues with the upgrade?  Any suggestions to help make it run smoother next time?  I have additional servers to upgrade In the near future, and am sure others could benefit from additional information.

Accepted answer

permanent link
Robert Swofford (31) | answered Aug 28 '15, 11:28 a.m.
I think I understand where the confusion is coming from. When you go to the interactive upgrade guide, it asks for previous installation path and new installation path. If you put in the ProdData paths, the upgrade guide is customized to use those paths in the upgrade command examples. You should always using the UserData for IBM i. Unlike other platforms, z/OS and IBM i have separate configuration paths from the installation paths.

For upgrading JTS from 5.0.2 to 6.0, you should:
  1. cd /QIBM/UserData/JazzTeamServer60/server
  2. upgrade/jts/ -oldJTSHome /QIBM/UserData/JazzTeamServer502/server/conf

When you run other scripts and repotools commands, you should be in the UserData directories.

Melissa Weaver selected this answer as the correct answer

Melissa Weaver commented Aug 28 '15, 2:17 p.m.

 Thank you.  I redid the upgrade guide with the UserData libraries, and the scripts now appeared to run correctly.  Thank you for the clarification 

I am verifying the upgrade, and am seeing in the Server Advanced Properties:  FullText Index location, and in the Jazz Foundation Services index location :   /QIBM/UserData/JazzTeamServer502/server/conf/jts/indices/workitemindex    and /QIBM/UserData/JazzTeamServer502/server/conf/jts/indices

Shouldn't those both be JazzTeamServer60????

4 other answers

permanent link
Robert Swofford (31) | answered Aug 26 '15, 5:16 p.m.
The problem may be that you are running repotools, upgrade, and was_upgrade scripts from the wrong directory. There are two directories you need to be concerned with. /QIBM/ProdData/JazzTeamServer[502|60]/server and /QIBM/UserData/JazzTeamServer[502|60]/server.

ProdData contains the CLM installation and UserData contains the configuration. As the "Run the upgrade script on IBM i" step in the documentation says, "In QShell, navigate to the Jazz Team Server 6.0 configuration directory /QIBM/UserData/JazzTeamServer60/server."

The verify should be run from /QIBM/UserData/JazzTeamServer502/server and the upgrade scripts and was_upgrade script should be run from /QIBM/UserData/JazzTeamServer60/server.

When you run repotools and jts/setup, the UserData versions of the are used and updated. The ProdData version remain in their original install state. Likewise, resetRepoLockId will update the UserData versions of the

Use -oldJTSHome
/QIBM/UserData/JazzTeamServer502/server/conf when running the jts upgrade script. For other applications use -oldApplicationHome with the same value.

As for, I will take your suggestion to improve the documentation and operation for this script. You can also look in the script to see the default values that are used by the script. The script will update applications that you installed in both 5.0.2 and 6.0 and will install new applications that you installed in 6.0 but had not installed in 5.0.2. It will not fail if the 5.0.2 applications do not exist, assuming of course the correct names are used.

permanent link
Melissa Weaver (621215) | answered Aug 27 '15, 6:41 p.m.
 Thank you for the clarification of the directories.   I restored my system back to Rel5.0.2 and tried the upgrade again.  I am still having issues.  
    the verify command worked, but it was still unclear as to which directory to use, I used the one you told me to. 
   The upgrade script still got an error for missing URI.  Here is the print of what I typed. 

cd /QIBM/UserData/JazzTeamServer60/server                             
upgrade/jts/ -oldJTSHome                                
got this error:                      
CRJAZ2106E The Public URL property "
" must be present in the file "/QIBM/ProdData/JazzTeamS
erver502/server/conf/jts/".  Add the property to the tea file and set the value to be the URI root that all clients
 use to reach the server.  The public URI root is essential for the proper fu
nctioning of your server. The upgrade will not succeed without this property.
  For more information, see the product documentation topic on "Planning your
The jts upgrade failed at step 0.  Correct the problem and run the script aga
in starting at step 0.     

So I think there is still a problem 

permanent link
Robert Swofford (31) | answered Aug 28 '15, 8:15 a.m.
Use -oldJTSHome /QIBM/UserData/JazzTeamServer502/server/conf when running the jts upgrade script. You used ProdData.

Melissa Weaver commented Aug 28 '15, 11:10 a.m.

I copied and pasted the commands from the user guide after changing the directory to UserData.     So are you saying that in the initial questions in the upgrade guide (Previous Installation  Path and New Installation Path)  I should use USERDATA for them?  Do I only use UserData for all the directories asked for in the upgrade process? 

In your previous answer you identified ProdData as the Installation directory, and UserData as the configuration directory.  Please clarify, I feel the instructions are not clear as to which directories to use.  
I am sorry If I am not getting it.  This is the first upgrade I have done, and I have found the instructions very unclear particulary in regards to directories)  and not always complete for an IBMi install.  

permanent link
Robert Swofford (31) | answered Aug 28 '15, 2:24 p.m.
Those values were carried over from your 5.0.2 The upgrade does not change that location.

Melissa Weaver commented Aug 28 '15, 2:52 p.m.

 That you.  I also created this work item    to have the instructions clarified. 

Your answer

Register or to post your answer.