It's all about the answers!

Ask a question

Problem with OSLC in Doors to get Requirements from a Folder.

Ian Giblett (2621216) | asked Jul 21 '15, 4:03 a.m.
edited Jul 21 '15, 5:01 a.m. by Ralph Schoon (62.7k33643)

I'm trying to create a consumer application for Doors Next Generation.
I want to create a tree view so that the user can click on a folders to see the requirements inside.

I'm trying to create the OLSC query URL which can get the requirements in a folder the but with no luck.
I have read the article:
but I'm missing something since every time I run the query, I get the error message is:

Error when converting: oslc.query=true& oslc.prefix=oslc& oslc.where=nav:parent Invalid prefix definition: oslc

My query base is

My folder url is 

As I understand, all I need to do is to add the following to the query base:

However,When I do an HTTP get on the following, I get the error message shown above. Could someone shed light on what is wrong with my statement?
This is what I'm posting<>,dcterms=<>,nav=<>&,dcterms:description,oslc:instanceShape&oslc.where=nav:parent=<>

Thanks in advance.

One answer

permanent link
Donald Nong (14.5k414) | answered Jul 21 '15, 6:39 a.m.
Yes it _should_ work. Constructing the URL is quite tricky and I suggest you escape the characters whenever possible to maintain the clear ?param=value&param=value format. Below is the URL that work in my CLM 5.0.2 environment.

Another tip is to check the rm.log file as it will show what the parameters are when the error occurs and you can adjust accordingly.

Sudipto Sarkar commented Aug 25 '16, 3:21 a.m.

I am using 6.0.1 RM server and I tried to replicate same query, but I am getting following exception:

java.lang.RuntimeException: Undefined namespace prefix: nav (More info found at entry [146e8a858b4f5d5a] in the RM application server log)</err:detailedMessage>
    <err:errorMessage rdf:datatype=""
    >Bad Request</err:errorMessage>
    <err:errorStatus rdf:datatype=""

Am i missing something.

Donald Nong commented Aug 25 '16, 5:10 a.m.

Yes, you missed the "nav" namespace specification. It's the last of the three namespaces defined in "oslc.prefix" in my example above.

Your answer

Register or to post your answer.