CLM 6.0 LQE and LDX failing to start on Websphere 8.5.5.6
I have just upgraded a basic CLM install from 5.0.2 to 6.0.0 which has gone as expected. Have then added RS/LQE/LDX/RELM/DCC and tried to run jts/setup.
The first time running all apps were registered and RS/RELM/DCC all setup fine. LQE and LDX were also detected and allowed me to setup an Oracle DB for them to use however the LDX had a failure - unspecified.
So I unistalled the components, cleared the websphere cache, reinstalled LQE and LDX however now they will not start at all to even get to setup just showing an Internal Server error.
The errors in the log are in the Websphere SystemOut.log
[16/07/15 15:49:05:421 ACST] 00000127 webapp E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [Servlet Error]-[com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor]: java.lang.NoClassDefFoundError: org.apache.http.impl.conn.ManagedHttpClientConnectionFactory (initialization failure)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:175)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager$InternalConnectionFactory.<init>(PoolingHttpClientConnectionManager.java:493)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.<init>(PoolingHttpClientConnectionManager.java:149)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.<init>(PoolingHttpClientConnectionManager.java:138)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.<init>(PoolingHttpClientConnectionManager.java:114)
at com.ibm.team.integration.core.common.http.HttpClientFactory.createHttpClient(HttpClientFactory.java:260)
at com.ibm.team.integration.core.common.http.HttpClientFactory.build(HttpClientFactory.java:168)
Any suggestions as to what the issue is?
Do I need the LQE as part of RS?
I assume the LDX is part of RELM? - Which is not a component we need to use.
Accepted answer
2 other answers
http://www-01.ibm.com/support/knowledgecenter/SSYMRC_6.0.0/com.ibm.jazz.install.doc/topics/t_deploy_was.html?lang=en-us
The steps for LQE and LDX from this document:
Configure the Lifecycle Query Engine (LQE) application
Procedure
- In WebSphere Integrated Solutions Console click .
- Click lqe_war to open it and then click Manage Modules.
- Click lqe, locate the Class loader order field and select Classes loaded with local class loader first (parent last).
- Click OK and save your changes.
- Go back to the lqe_war application and click Class loading and update detection.
- On the Class loader page, select Classes loaded with local class loader first (parent last).
- Click Apply and Save directly to the master configuration.
Comments
If you want to re-register LQE/LDX application when RELM is involved, you need to:
- Locate the lqe.properties file. By default, the lqe.properties file is in the /server/conf/lqe folder. The location is also the value for this JVM system property: -Dlqe.config.location , which is in the same folder.
- In the lqe.properties file, set this LQE property: configMode=true .
(the same should apply to LDX)
Restart WAS with LQE/LDX and try to run jts/setup again
I am not sure if you need RELM or not from your description. Lifecycle Query Engine is supported as a data source for use with Rational Engineering Lifecycle Manager, but is an unsupported technical preview feature for any other CLM 6.0 application. LQE as a data source for reporting on configurations is also in technical preview, even with Rational Engineering Lifecycle Manager. See the details in
So if you dont use RELM and reporting on the new configuration data source is not required, you dont need to have LQE.
LDX is a small instance of LQE and it is actually used by CLM backlink query. So if you have LPA in 6.0 CLM, you would want to have LDX in order for you to still see the backlink in QM and RM.
Hopefully these help.