It's all about the answers!

Ask a question

Problem to login in DCC


Luiz Almeida (23014876) | asked Jul 03 '15, 11:46 a.m.
edited Jul 03 '15, 11:47 a.m.
Hi guys,

I have installed and configured DCC. Now I am trying to collect data following these instructions.
In step 3, if I try to login with Jazz Admin user, I cannot acces (Invalid User). If I provide the user used to configure and deploy dcc.war in websphere, I do login, but the following error is raised:

CRRCD1500E An exception net.oauth.OAuthException was captured in the function call com.ibm.team.repository.service.internal.oauth.OAuthServiceProvider class runAsUser
JTS is configured to use LDAP authentication, so my doubt is: at this point, DCC should be using the JTS authentication, right?

What am I doing wrong? Unfortunatly the instructions are not precise in Information Center.

Since now, thanks a lot.

2 answers



permanent link
Rafik Jaouani (5.0k16) | answered Jul 03 '15, 11:58 a.m.
JAZZ DEVELOPER
Hi Luiz,
DCC should be registered as an app to the same JTS as CCM, RQM, etc...
Try running : https://server:port/dcc/admin#action=jazz.viewPage&id=com.ibm.team.repository.users
and see if the user is there. I am suspecting the DCC had not finished synching its user list with the JTS.

Comments
Luiz Almeida commented Jul 06 '15, 12:51 p.m.

Rafik,
Running the link you suggested, I can see the user, but when i try to login with it, the following error is shown:

[06/07/15 09: 55: 03: 984 EDT] 00,000,090 LTPAServerObj E SECJ0369E: Authentication failed when using LTPA. The exception is com.ibm.websphere.wim.exception.PasswordCheckFailedException: CWWIM4537E No owner located from owner 'jts_user'.


My scenario is: I have JTS and CLM applications installed in "serverA" using WAS and LDAP authentication. I have ReportServer and DCC installed in "serverB" using WAS. To do the setup of JTS I have the user "jts_user", but to configure and deploy DCC I used the user "dcc_user" (this user is not in Active Directory).

Now that I am trying to authenticate the DCC application set up on the Jazz™ Team Server, I am trying with "jts_user".

Do I have to configure something in WAS of "serverB" to authenticate with LDAP too? Or do I have to include "dcc_user" in Active Directory?

Thank you so much.


1
Rafik Jaouani commented Jul 06 '15, 1:56 p.m.
JAZZ DEVELOPER

jts_user and dcc_user are what we call functional users that should not be used for login purposes. You configure DCC like any other CLM application (RTC, RQM...) and you use a real jazz admin user that exists in your LDAP to login to it. If problems persist, I would recommend you contact IBM support so they can walk you through the procedure.


Luiz Almeida commented Jul 06 '15, 2:16 p.m. | edited Jul 06 '15, 2:17 p.m.

Sorry Rafik... My explanation was not good. Where I mentioned "jts_user", in true, I wanted to mention "jazzadmin_user". But I will follow your suggestion and to contact support, because I'm doing configuration as you described and the problem continues.

Thank you.


permanent link
Luiz Almeida (23014876) | answered Jul 23 '15, 10:54 a.m.
I solved the problem configuring the WebSphere where DCC is deployed to use LDAP authentication.

Your answer


Register or to post your answer.