It's all about the answers!

Ask a question

Custom work item large html type not working

James Cheung (671116) | asked Jun 01 '15, 8:36 p.m.
 Hi all,

A custom field with type 'Large HTML' used to work in v4 to display a table. Now, RTC is upgraded to 5.0.2. The html type is behaving like a string field. 

Any idea how to fix it?

My issue is very similar to this. I followed the hint to check the attribute warning/error, but found nothing.

My issue is exactly this one.

Please help.

Best regards,

Don Yang commented Jun 01 '15, 9:57 p.m.

what version did you use in v4.x which worked for you?
how was the table created in v4.x?
if you create a new Large HTML custom attribute in 5.0.2, do you see the similar result as the one upgraded from v4.x or not?
have you tried on different browser or not?

Ralph Schoon commented Jun 02 '15, 2:43 a.m.

I would consider to go to the editor presentation and check that. Are there different modes available? Maybe changing, saving, changing back helps?

James Cheung commented Jun 02 '15, 4:53 p.m.

Hi Don, thanks a lot for your help.

1. It was working on RTC 4.0.6 until we upgraded to 5.0.2;
2. The HTML table in that attribute is being created and populated by a Java program. I am not the developer for it;
3. I tried to change the attribute from large HTML to small HTML, but the issue is the same;
4. I tried Chrome and Eclipse client, same issue;

Hi Ralph,
I went to the editor presentation, but not sure about different mode. I did the change and save.

Thanks all.

James Cheung commented Jun 02 '15, 4:55 p.m.

Hi Ralph,

I am trying to isolate our java code from the issue here. Hence, I used your WCL 2.2 to update the field. 

wcl -update projectArea="EIS" repository="" password="xxx" user="xxx" workItemType=EIS_RI /ignoreErrors id="215096" EisActiveEnvironment:set="<i><b>James Test</b></i>"

It works!!! The attribute can be shown as italic and bold now. 

The reason I used above as test is because there is no double quote within the EisActiveEnvironment:set. I found great issue to escape double quote in DOS command.

Do you know of any syntax I can try?

I tried these with "" or ^" to escape the double quote, i.e. <table border=""1"">

James Cheung commented Jun 02 '15, 4:56 p.m.

I tried these with "" or ^" to escape the double quote, i.e. <table border=""1"">

wcl -update projectArea="EIS" repository="" password="xxx" user="xxx" workItemType=EIS_RI /ignoreErrors id="215096" EisActiveEnvironment:set="<table border=""1""><tr><th>Table header</th><th>Table header</th></tr><tr><td>Table cell 1</td><td>Table cell 2</td></tr><tr><td>Table cell 3</td><td>Table cell 4</td></tr></table>"

Sorry this is more on DOS command question.

James Cheung commented Jun 02 '15, 5:09 p.m.

May be I should ask a question about the HTML table support in an Large HTML attribute. Does it support HTML table in 5.0.2? I pretty use it worked in 4.0.6.

showing 5 of 6 show 1 more comments

Accepted answer

permanent link
Grazielle Codogno (15316) | answered Jun 22 '15, 8:10 p.m.
Hi James,

The Supported tags by RTC in  Large HTML, are  Italic and Bold tags.
James Cheung selected this answer as the correct answer

One other answer

permanent link
Ralph Schoon (63.2k33646) | answered Jun 03 '15, 2:49 a.m.
edited Jun 03 '15, 2:50 a.m.
In 5.0.2 I was able to use my work item commandline to create a table in a large HTML attribute.
Please note that the UI does not allow to add the tags for a table manually.

I used \ to escape the " after looking it up in the internet. I also did not escape it at all.

Not sure if this does what you want or if border is supported. I was unable to see a border.

James Cheung commented Jun 03 '15, 2:52 p.m.

Thanks Ralph,

I also followed Don's suggestion to create a new HTML attribute, then test with WCL. I got the same issue. When I ran a restful query to see the content of the attribute, I found that RTC removed all of the HTML tag.

<rtc_cm:EisActiveEnvironmentNew>Table headerTable headerTable cell 1Table cell 2Table cell 3Table cell 4</rtc_cm:EisActiveEnvironmentNew>

Would you please elaborate more on the Editor Presentation that I should have checked?

I wish I could have posted screenshot here about my Editor Presentation setup.

Best regards,

James Cheung commented Jun 03 '15, 3:09 p.m.

Hi Ralph,

Would you please do me a favor to run a test on your environment with your WCL to update a HTML attribute.

wcl -update EisActiveEnvironmentNew:set="<font color=\"red\">This is some text!</font>"

Do you see the red color text? I don't on my environment. 

Best regards,

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.