It's all about the answers!

Ask a question

Moving components between servers (repositories)

Christine Makasy (73822) | asked May 28 '15, 4:57 a.m.
Moving a component between repositories located on two servers are only possible if the performing user has JazzAdmin rights. For all others he gets the error message "User 'x' does not have permission to read component 'y'. (Deliver operation). Checking the component it is assigned to the team he belongs to and he is also in the appropriate team available in destination server.

Now my question: Is this the right behavior or is this a bug?

One more question: Is there a specific permission to allow/prevent this operation. The replicate permission doesn't work.
And what about change sets? Is a user allowed to flow change set to a destination where he is not allowed to deliver an entire component?

Many thanks for clarification in advance.
Cheers, Christine

Accepted answer

permanent link
Kevin Ramer (4.5k6175193) | answered May 28 '15, 1:45 p.m.
I found a similar situation and asked about it here    What Ralph is saying is true; when a component is replicated into a different repository it will have some project (or team) area as an owner.  The default for RTC ( since v3 ) is that only members of a project hierarchy are permitted read access, so if a user is a member of a different project than owns the component and has no membership to the owning project/team ( or possibly in the authorized user list ), actions against those components will be met with the same error.

What some of the reference material above fails to mention is that a delivered component exists only one time in the remote repository which leads to the permission concerns and no small amount of user confusion.

Christine Makasy selected this answer as the correct answer

Ralph Schoon commented May 29 '15, 3:12 a.m.

Thanks Kevin for pointing this out. I have worked with this scenario, but obviously it is easy to do something wrong and to get stuck. This explanation helps.

One other answer

permanent link
Ralph Schoon (61.8k33643) | answered May 28 '15, 5:05 a.m.
I am pretty sure, that you do something wrong in the permission/role set up of the user performing this operation. JazzAdmin rights should not be needed for this operation. The user just needs the correct permissions in the projects(s) that own the components and in the project on the second server.

Please see
  for considerations around permissions.

Christine Makasy commented May 28 '15, 8:39 a.m.

In our Project Setup the mentioned permissions for Source Control are included in used role itsself. But nevertheless I got the mentioned error + details: The operation is not governed by process. (distributed SCM is enabled)

Do you have one more idea?
Many Thanks, Christine

Ralph Schoon commented May 28 '15, 8:43 a.m. | edited May 28 '15, 8:43 a.m.

What puzzles me is that the error says "User 'x' does not have permission to read component 'y'. (Deliver operation). So somehow the user is not able or does not have the permission/access to the owning project area of the component.

I'd try to have the user create a repository workspace on that machine first and try to load all components. If that works have a new stream/repository workspace created on the other side. And try if the user can load the distributed workspace. Then try to deliver on this server.

Ralph Schoon commented May 28 '15, 8:47 a.m.

Please also note, that the component does not move. A new component is created and then the change sets are replicated into the other server. The change sets will be on both servers and you will have two components that are associated, but live on different servers..

Christine Makasy commented May 29 '15, 7:20 a.m.

Many thanks, the reaseon for this misbehavior was the ownership of the component.

Your answer

Register or to post your answer.