It's all about the answers!

Ask a question

When I run the OOTB reports from the shared reports, most do not work for me.

Brian Mooney (11711) | asked May 12 '15, 3:08 p.m.
When I run the reports from the shared reports, most do not work, for example when I run Open vs Closed Work Items or Story Points by Iteration, I could list many, it states  "No work items were found" or "No story work items were found."  But when I run the report Work Items by Owner the report runs and shows "Work items by type" and "Open vs closed work items" in a graph and successffully.  I have created a new Timeline and have a number of iterations listed under them, a number of tasks, stories, defect all associated with the timeline, but when I run reports I can't find them choose them to run reports against.  I have set my time line as the current Timeline to use, I'm am thinking maybe a configuration issue or permission issue, but I am lost. 

4 answers

permanent link
Brian Mooney (11711) | answered May 21 '15, 2:28 p.m.
She is creating a work item query.  I have run some of the reports mentioned above on other projects and they don't produce data either.  There are some that run and some that don't.  Maybe that is the way it goes.  I'm not actually sure how to validate the data is actually in the data warehouse with out having the DBA validate it for me.  I can submit a ticket to IBM support, but I'm not sure there is more to cover.  Not sure what/how to ask them to do other than running a query directly against the DW DB.  She is currently fine for the time being.  This is for proof of concept PA for entering in work items, an area to play with before prod.  I would assume that both this area and prod are configured the same, but I don't know that, because I don't have rights over the Prod area, just the pilot area.  Thanks for all the help.  Will see how things go moving forward. 

Alanna Zito commented May 22 '15, 3:41 p.m.

Yes, you would need a DBA (or someone with access to the database) to run some queries on the data warehouse to validate that the correct data is there.  That's something that IBM support could help with (in terms of what queries to run or what tables to look at).   

permanent link
Brian Mooney (11711) | answered May 21 '15, 12:25 p.m.
Sorry for the long delay, been a busy week.  Yes we have validated jobs are running in both jts and ccm successfully.  The work Items do seem to be assigned to the right iterations and timelines.  Not really sure what else to check/look at.  The user was able to create a query to pull the data she wants, just doesn't have a pretty graph/report to look at it.  She obviously would like the report features to work as intended, but can deal with the query she created, getting similar results. 

Alanna Zito commented May 21 '15, 1:56 p.m.

When she say that she can run a query to get her data - do you mean she's running an SQL query on the actual data warehouse?  Or is she creating a work item query?  The reason I ask is that it would be useful to verify whether or not the expected data is in the data warehouse (if it's not, then there's probably an issue with the data collection jobs; if the data is in the warehouse, but not showing in a report, then it could be a problem with the report configuration). 
At this point, I think we've checked all the obvious causes for this problem - your best bet might be to log a ticket with IBM support so that they can help troubleshoot this in more detail.

permanent link
Brian Mooney (11711) | answered May 12 '15, 5:03 p.m.

Thanks for your response.  I have admin access and have validated the collection jobs are running and I have also had another team member with admin access check and the jobs are running at 11pm everyday.  There has been data in the project area for several weeks, like I said some reports work but others do not.  The one thing we have noticed is that when you edit a report it doesn't list the timeline we are using.  It shows the main timeline, but not the timeline we created or the iterations underneath it.  Maybe there is something wrong with how we setup the timeline. 

Like I said earlier,  Open vs Closed Work Items doesn't work, but Work Items by Owner the report runs and shows "Work items by type" and "Open vs closed work items" in a graph and successffully. 

Alanna Zito commented May 14 '15, 9:17 a.m.

Hmm, that's strange.  Just to confirm - did you check that the jobs were running successfully in both the JTS and CCM? (I forgot to ask - are you using DCC or the built-in jobs?  What version of RTC is this?) 

Re: not seeing your timeline show up - again, this could be caused by the jobs not running correctly.  Another possible reason is that, in most reports, it will only show parameter values for which there are assigned work items - e.g., if there's a parameter called "Iteration", it will only allow you to choose from iterations that have some assigned work items, not all iterations that are defined in the project area.

permanent link
Alanna Zito (1.3k3) | answered May 12 '15, 4:41 p.m.
Hi Brian,

It sounds like the data collection jobs are not running on your server.  Many of the shared reports (e.g., Open vs Closed Work Items) pull their data from the data warehouse.  Make sure that the jobs are running successfully (you may need to ask your server administrator).  Also, if you've only recently created your timelines, work items, etc., then they won't show up in the reports until the next time the data collection jobs run (usually once a day). 

The Work Items by Owner report does pull live data from the repository, which would explain why it's working when the other reports aren't.

Your answer

Register or to post your answer.