It's all about the answers!

Ask a question

Issue with Rational Publishing Engine retrieving data from Rational Team Concert schema.

Graham Whalley (611) | asked Apr 01 '15, 4:15 a.m.
We are running reports in RPE (v1.3.0) using REST services to pull Work Item data from a Rational Team Concert schema and are getting this error when we run the document generation.....

CRRPE3107I Downloading data from|id|summary|category/(name)|children/(id)|foundIn/(name)|owner/(name)|projectArea/(name)|target/(name)|type/(name)).
CRRPE1064I Error in engine
Auto: connection to failed. None of the known protocols succeeded.

CRRPE1064I Aborting engine execution...
CRRPE1064I 7 publishing commands are processed. 0 publishing commands remain to be processed.
CRRPE3097I The document template is processed. If there are no more templates to process, output files are being written.
CRRPE1064I Document generation finished in 136 seconds.
Cache information
CRRPE1022I The process was completed in 136.912 seconds.
CRRPE1023E The document could not be generated.

The error only appears when trying to retrieve certain data items (for example - type/(name)) from the schema; if we drop these from the Document Template the remaining items are being retrieved successfully and the document generates perfectly well. It's as if my ID doesn't have the necessary permissions to access a few of the data items in the schema.

Can anyone offer any advice please?




One answer

permanent link
Subramanya Prasad Pilar (4.6k16) | answered Apr 01 '15, 5:28 a.m.
Hi Graham,

Can you please try the same URL on a browser and see if you can access the user/password that you provided in RPE?

If yes, you can try setting different Authentication type for the data source in RPE (Launcher).


Graham Whalley commented Apr 01 '15, 5:45 a.m.

Thanks for the quick response Prasad.

When I try the URL, it allows me to sign on using the credentials from RPE but I get this error....

Error 500: CRRED8021E: Internal Repository Error Caused by: [CRJAZ1316E The user "" does not have permission to read items that have the ProjectArea access type.]

If I drop the '|type/(name)' from the URL and try it again, it works and all the other data is being returned just fine. It's as if I do not have permission to read '|type/(name)' from the schema. However, we do need this data in the report we're trying to run.

I've tried using all the different Authentication types in the Launcher but get the same result. Currently, it's set to 'Auto' which I was told, would automatically sign me on using the appropriate authentication method.

Any other ideas please? Thanks.

Graham Whalley commented Apr 01 '15, 9:06 a.m.

Hi. A further update.....

It looks as if my ID isn't set up as an Administrator for our Project Area in RTC and this may be one of the reasons I am not able to see some of these 'ProjectArea' data items. In addition to this, my ID may also need 'JazzAdmins' permission as certain '' parameters may need to be updated on the Admin server. The Rational Tools Services support team are progressing this for me.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.