It's all about the answers!

Ask a question

CRJAZ1933E error setting up JTS through express setup


Simon Fox (3556) | asked Mar 14 '15, 9:17 a.m.
Hi,
I've installed the latest JTS (5.0.2) for evaluation and I'm setting it up using TomCat and Derby databases.  During installation I used all default options except the installation folder and the Java memory settings which I reduced as follows:
set JAVA_OPTS=%JAVA_OPTS% -Xmx1G
set JAVA_OPTS=%JAVA_OPTS% -Xms1G
set JAVA_OPTS=%JAVA_OPTS% -Xmn512M
TomCat started with no issues and I was able to connect remotely to begin configuring the server which I did using the express setup option.  Everything went smoothly until the final step when I got the following error:
"CRJAZ1933E - A serious error occurred indicating a server configuration problem. The server received a request for OAuth authentication, but was unable to find or load the service that handles the authentication request. The server is mis-configured, and is probably showing other errors as well. Consult the system logs for further information on why this authentication service is unavailable."
I am installing on less than optimal hardware which could be a factor (I have only 2GB RAM which is why I reduced the RAM available to Java) but I was hoping I would get away with this as I'm only going to run CM without QM & RM.  The machine is running WIndows 7 Professional 64bit, not Windows Server.
I was wondering if anyone can tell me what the actual minimum memory requirement is if I only want to run CM and also whether Windows 7 Professional should work or if there is something specific about the Windows Server OS that I need.  I do not have a domain and don't want or need the hassle of setting one up.
I do realise that the answer probably lies in better hardware but I want to know exactly what's really necessary before I spend any money, hence the questions.  Also, the error message says I should check the system logs for more information.  Can anyone point me at the correct logs?

Many thanks in advance,

   Simon.

2 answers



permanent link
Simon Fox (3556) | answered Mar 16 '15, 8:41 p.m.
Hi Lawrence and many thanks for the response.

In answer to your question: I don't think I made a choice about whether or not to use TomCat user authentication.  There are very few questions in the express setup and I don't recall that being one of them but I may be mistaken.

I checked my teamserver.properties file for CCM and it had the following for the webapp.url:
com.ibm.team.repository.server.webapp.url = https\://host\:port/jts
which doesn't match what you state.  There was no setting present for jts.url.
I changed the webap.url setting and added the jts.url setting and tried the express setup again but got an error because it said I could not change the URI once configured.  I reverted to the previous settings and, like my first attempt I go an error on the final step "Finalize lifecycle project administration setup" but this time it was a different error:
Expected status 202 returned from "https://rtcserv-pc:9443/jts/lifecycle-project/finalize-setup?client=scripted", but was 500 Use the Custom Setup to run the setup instead of using the Express Setup.ID CRJAZ2248E.

I think maybe I need to start from scratch.  I've got a manic couple of days coming up but when the dust settles I'm going to try to uninstall everything and try again:-(

Many thanks,

   Simon.

Comments
Lawrence Smith commented Mar 27 '15, 9:53 a.m.
JAZZ DEVELOPER

Yes once the url is set it must be changed using repotools...


But if you are just starting, starting from scratch may be simpler.


permanent link
Lawrence Smith (3764) | answered Mar 14 '15, 10:18 a.m.
JAZZ DEVELOPER
We run on all sorts of Windows... I use Windows 7 Professional. That should not be a concern.

In our Jetty server configurations (run within Eclipse) we run with a small memory footprint... 
-Xmx512M
-XX:PermSize:64M 
-XX:MaxPermSize:256M

I'd have to look up the Java memory parameters, but unless you are getting an out-of-memory error you shoudl be OK.

When you set up the server with 
http://localhost:9443/jts/setup 

Did you configure to use Tomcat user authentication in Setup User Registry?

You need to make sure your url's are correctly set up, host name and/or hosts/etc file is configured properly, and firewalls are not blocking requests.

Here is an article on configuring the server: https://jazz.net/library/article/304

See also:  http://www-01.ibm.com/support/docview.wss?uid=swg21691301
To resolve this setup issue, shutdown the IBM Rational Collaborative Lifecycle Management (CLM) server and add the following parameters to both  teamserver.properties files for CCM and Quality Management (QM) applications:

  1. teamserver.properties  file for CCM


    com.ibm.team.repository.server.jts.url = https\://host\:port/jts
    com.ibm.team.repository.server.webapp.url = https\://host\:port/ccm

  2. teamserver.properties  file for QM


    com.ibm.team.repository.server.jts.url = https\://host\:port/jts
    com.ibm.team.repository.server.webapp.url = https\://host\:port/qm


Lawrence Smith [IBM]

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.