It's all about the answers!

Ask a question

Jazz Reporting Service "Connect to Data Sources" error

Mike Shkolnik (9808161143) | asked Jan 09 '15, 7:08 p.m.
edited Jan 09 '15, 7:14 p.m.
"The server was unable to connect to the database. Try entering the password again or confirm that the database is available."

I entered the correct password but it's not working. I can log into SQL Management Studio, RTC connects and runs data collection jobs without issue, and RRDI is working as well. I previously followed these instructions and to be sure restarted both Tomcat and WAS and tried again without luck. What step am I missing?

My Setup:
WAS Server with DCC, RRDI, and JRS on Windows 2012
TOMCAT server with JTS and CCM on Linux 6.4
SQL Server 2012 - all databases on same server
Everything is 64 bit

Steps I followed:

Add WAR file to WAS: 
Applications/Application Types/Websphere Enterprise Applications 
C:\Program Files\IBM\RRDI\jrs\JazzTeamServer\server\tomcat\webapps 
Select rs.war 
Next (wait), Next, Next, Next, Next 
Make sure Context Root = rs 
Next, Next, Finish (wait), Save 
Environment/Shared Libraries 
Scope = Cell (also tried Node) 
Name: JRS Shared Libraries 
C:\Program Files\IBM\RRDI\jrs\JazzTeamServer\server\conf\rs\WAS_SharedLibrary 
Check use an isolated class loader 
Applications/Application Types/WebSphere Enterprise Applications 
Shared Library References 
Click rs_war 
Click Shared Library References 
Check rs_war 
Click Reference Shared Libraries 
Select JRS Shared Libraries + right arrow, 
OK, OK, Save 
Servers/Server Types/Websphere Application Servers 
Click RationalReportingServer 
Java & Process Management/Process Definition 
Click Java Virtual Machine/Custom Properties 
file:///C:/Program Files/IBM/RRDI/jrs/JazzTeamServer/server/conf  
OK, Save 
Copy jdbc driver (sqljdbc4.jar) to WAS shared library folder 
StartMenu/Stop the server (run as administrator) 
Wait until cmd window closes 
StartMenu/Start the server (run as administrator) 
Wait until cmd window closes 
Register Application 
Add Application 
Instance = /rs 
DiscoveryURL = https://WASSERVER:PORT/rs/scr 
Application Type and Functional User ID will autofill 
Click Register Applications 
Add RTC Outbound Connection 
Click Add 
Name: JRS 
URI: https:WASSERVER:PORT/rs/rootservices 
Secret: (use same as did for RRDI) 
Check Trusted 
Click Create Friend 
Next, Finish 
Add RTC Inbound Connection 
Consumers Inbound 
Connect to Data Sources
Prompted to enter password for JAZZDBUSER 
Enter jazzDBuser password (FAILS)
Import Reports (didn't get there yet since prior step failed) 

3 answers

permanent link
Mike Shkolnik (9808161143) | answered Jan 12 '15, 1:40 p.m.
edited Jan 12 '15, 1:45 p.m.
Due to the JRS setup not properly copying the database string from the JTS, I set up a data source manually on the Data Source tab (oddly enough by copy/pasting the string verbatim from the JTS data warehouse connection page). This seems to work. I was able to import the ready-to-use reports. Not sure why the JRS setup does this wrong when the string is clearly correct in JTS.

permanent link
Francesco Chiossi (5.7k11119) | answered Jan 12 '15, 4:35 a.m.
Hello Mike,

do you get any entry in the rs.log file when you get the error message in the WebUI?

Best Regards,

Francesco Chiossi

Mike Shkolnik commented Jan 12 '15, 12:19 p.m.

Indeed I did. And I see the problem. There is no slash of any kind between the server name and the instance name. This must be a bug in the RS setup since the data warehouse is not setup as part of the RS install - it pulls that data from JTS. So how do I fix this?

Mike Shkolnik commented Jan 12 '15, 12:55 p.m.

 Here's another funny thing (aka bug) - the UI properly shows the backslash:

"Enter the password for the database user jazzDBuser of the data warehouse on SERVER\I01"

While the log file clearly doesn't:

!CRRGW6018E The server was unable to connect to the following database: "//SERVERI01:PORT;databaseName=DBNAME;user=xxxxxxxx;password=xxxxxxxx"

permanent link
Kevin Cornell (5411) | answered Jan 12 '15, 9:48 a.m.
Can you please attach the rs.log file.

Above you indicate the topology as "WAS Server with DCC, RRDI, and JRS on Windows 2012". Are all three applications in the same WAS profile or are they in different profiles?

Mike Shkolnik commented Jan 12 '15, 12:20 p.m.

 I believe all in one profile. But this is my first time using WAS. :-)

Kevin Cornell commented Jan 13 '15, 9:13 a.m.

If I recall, DCC, RRDI and JRS are installed on disk into different folders in 502 (or at least JRS was). If you go to <installDir>/server/conf do you see both application folders for dcc and rs? The JAZZ_HOME custom JVM property in WAS must be set to the server/conf folder that contains all of the applications deployed to that profile. If the applications are not in the same server/conf folder, then they cannot be in the same WAS profile.

As for the SQL Server database location, JRS obtains that location URL directly from JTS. It does not modify it in any way. I have not seen this "SERVER|instance" notation  before. In any case, as a JRS administrator you can go to the Data Sources page in JRS and manually create or modify the data warehouse connection information.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.