It's all about the answers!

Ask a question

RQM - Uploading Attachment via REST API/RQMUrlUtility


Liora Milbaum (513282117) | asked Jan 06 '15, 3:40 a.m.
 CLM 5.0.2

Following RQMUrlUtility, I have issued the next command to upload an attachment:

java -jar RQMUrlUtility -command POST -user build -password build -filepath C:\temp\importing.log -url https://server:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/JKE%20Banking%20(Quality%20Management)/attachment

The output seems like the command succeeded:

                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                                  <<<<<----- [ RQMUrlUtility ] ---->>>>>
                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Default cookie policy RFC_2109 is used.
RQMUrlUtility: Connected to https://server:9443 using project "JKE+Banking+(Quality+Management)"
Attempting to create SSL_TLS context
RQMUrlUtility: Calling [ HTTP POST ] method to upload XML from a specified file to URL
RQMUrlUtility: Server Response code: 201
RQMUrlUtility: [ SUCCESS ] File : "C:\temp\importing.log" successfully posted to URL : "https://server:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/JKE+Banking+(Quality+Management)/attachment "
Slug: Content-Location: slug__3ZpDkJV-EeS778qLKYfUqw

Disconnecting from the IBM Rational Quality Manager server.

BUT, I can't see the attachment in the attachment feed, nor I can attach it to a specific resource.

Is there something wrong with the command above?

Liora



4 answers



permanent link
ameen ezath (111) | answered Sep 25 '19, 4:40 a.m.

 If this thread is not intended to solve the problem nor share the solution better close it saying not resolved.


permanent link
Sonali Jathar (11) | answered Dec 06 '18, 6:36 p.m.

 how to get slug ID in success response i am not able to get that? 


permanent link
Frank Lautenbach (312) | answered Jul 14 '16, 11:00 a.m.
Hi Liora, nice that you were able to resolve the issue, however, I am struggling with a similar issue so maybe you can share the solution with the community? Thanks!

Comments
Liora Milbaum commented Jul 14 '16, 12:10 p.m. | edited Jul 14 '16, 12:16 p.m.

Long time passed since than. Don't really remember.

BUT, I was able to add the attachment.

Let me add my customer to this discussion and he might find you the relevant code. 


Frank Lautenbach commented Jul 15 '16, 3:02 a.m.

When you say "I was able to add the attachment" do you mean you were able to add a link to the attachment to another artifact (e.g. an execution result) via REST API? I have been told it would not be possible because attachment and contribution elements are defined as read-only.


Liora Milbaum commented Jul 17 '16, 6:06 a.m.

 Yes. I was able to do it.  I have received my customer approval to publish the code snippet.  He will do that later on.


Frank Lautenbach commented Jul 18 '16, 2:38 a.m.

Great, thanks in advance!


permanent link
Liora Milbaum (513282117) | answered Jan 06 '15, 7:21 a.m.
 Please ignore.  Found the solution.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.