It's all about the answers!

Ask a question

Can not upgrade to 5.0.2, the old version recognized as 5.0.2


Amir Sinay (181020) | asked Dec 23 '14, 4:47 a.m.
 Hi,

I'm trying to upgrade my CLM 5.0.1 to 5.0.2. This is a one server installation with tomcat 7(derby). I followed all the steps in the interactive installation manager, and when I'm trying to run the following command:
"upgrade/jts/jts_upgrade.sh -oldJTSHome /opt/IBM/JazzTeamServer_5.0.1/server/conf"

I got the first choose [E], [S] or enter step. I press E, and after a few seconds It stopping the upgrade and give me the following error:

"Validating JTS configuration files...
Checking the old JTS version...
CRJAZ2132I The old JTS version is "5.0.2".
CRJAZ2624I The new JTS version is "5.0.2".
CRJAZ2122E The old JTS version "5.0.2" is not a supported version for this operation. See the help topic "Upgrading the Rational solution for CLM".

Copying query and search indices from '/opt/IBM/JazzTeamServer_5.0.1/server/conf/jts/indices/' to '/opt/IBM/JazzTeamServer_5.0.2/server/conf/jts/indices'.
This may take several minutes...


The jts upgrade failed at step 0.  Correct the problem and run the script again starting at step 0."
I checked my version and it's 5.0.1 not 5.0.2. What am I doing wrong? Is there an option to resolve this?

Thanks in advance.

Accepted answer


permanent link
Yaron Norani (47246860) | answered Dec 24 '14, 6:16 a.m.
Found the solution: Please add the following parameter: -oldJTSVersion 5.0.1  (or your other old JTS version).
Amir Sinay selected this answer as the correct answer

Comments
Amir Sinay commented Dec 24 '14, 6:59 a.m.

 This actually helps, however this is a workaround. I think IBM need to take a closer look in to that bug.

2 other answers



permanent link
Shimon Nir (24715) | answered Dec 23 '14, 10:37 a.m.
Call me if you still have the problem 052 2554950

permanent link
Francesco Chiossi (5.7k1819) | answered Dec 23 '14, 7:30 a.m.
Hello Amir,

I would try to copy the derby database files again from the 5.0.1 installation to the 5.0.2 installation and rerun the upgrade scripts.
It could be that a previous attempt to run the script failed or the databases where not properly copied over.

See section 6 Copy the Derby databases from the previous installation directory to the new installation directory of the interactive upgrade guide.

Best Regards,

Francesco Chiossi

Comments
Amir Sinay commented Dec 24 '14, 12:54 a.m.

Hi Francesco,

I tried to copy the DB again, also using the verbose option and there were no errors what so ever. After that I tried to run the upgrade script again and got the same error. 


Yaron Norani commented Dec 24 '14, 5:04 a.m.

Hi,

performing the same process while upgrade from 5.0.1 to 5.0.2. Same error. Please advise,
 To find more information about a message, see the online product documentation.
CRJAZ1363I Loading the configuration from "bundleresource://171.fwk1271942096:1/teamserver.properties".
Validating JTS configuration files...
Checking the old JTS version...
CRJAZ2132I The old JTS version is "5.0.2".
CRJAZ2624I The new JTS version is "5.0.2".
CRJAZ2122E The old JTS version "5.0.2" is not a supported version for this operation. See the help topic "Upgrading the Rational solution for CLM".


Your answer


Register or to post your answer.