It's all about the answers!

Ask a question

RTC and intellij integration problem

Laurynas Simaitis (612) | asked Dec 22 '14, 8:54 a.m.
 After we migrated to RTC server 5.0.2 I can not setup my Intellij Idea to work with RTC.

I have updated my RTC Eclipse/RAD client to 4.0.6 via installation manager. I have checked Eclipse/RAD integration with server and it works fine;

I have updated Intellij Idea plugin to new version (actually, I have tried both 4.0.6 and 5.x versions);

I have tried various versions of SCM tools (4.0.6 and 5.0.2);
scm -v returns Build Id: RTC-I20140205-1437, team.filesystem.cli.client, version 3.2.100.v20140114_0303

when I try test connection to RTC server, I get error:

Problem running 'login':
Could not log in to https://###:9443/jazz/ as user ###@###: Your client is version 3.0.1, and the server is version 5.0.2.  These versions are not compatible. Server Version: 5.0.2. Client Version: 3.0.1. Your client is not compatible with the server. Update your client from https://######:9443/clmhelp/topic/ topics/c_upgrading_clients. html.

Probably I'm missing some install, but after all trials and failures I'm out of ideas, what to try next.

sam detweiler commented Dec 22 '14, 9:32 a.m.

Sounds like your intellij config is incorrect, and points to the wrong  scmtools path..

https://###:9443/jazz/  is the old pre-CLM rtc url.. should be https://###:9443/ccm
also the client error " Your client is version 3.0.1, and the server is version 5.0.2. "
indicates a path problem somewhere..

One answer

permanent link
Laurynas Simaitis (612) | answered Dec 22 '14, 10:13 a.m.
   Thanks for response!

Actually something has been cashed, because after complete system restart, the earlier error message have disappeared.  

I have other issues now, but I think it is related to Intellij Idea RTC plugin.

By the way, my environment is:
Ubuntu 12.04 LTS
Idea 14.0.2
RTC server 5.0.2
Eclipse plugin version 4.0.6

Your answer

Register or to post your answer.