It's all about the answers!

Ask a question

Did installing Oracle Java 8 break my RTC server?

Christopher Smith (111) | asked Dec 08 '14, 10:44 p.m.
retagged Dec 09 '14, 9:45 a.m. by Laura W. Hinson (16126)
 I've had RTC 5.01 installed and running on Debian 7 for about 2 months.

I'm running with Tomcat and Derby installed using the setup in a relocatable folder method.  I also installed the build engine using the debian deb archive.

I wanted to start building for Java 8.  I installed a Luna eclipse with the RTC Client installed in /home/jbe/eclipse (I did not check to see if there was already an eclipse folder there) and then found a package that in installs Oracle Java 8 jdk using apt-get.

When I ssh into my server, java -version returns 
root@debian64:~# java -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

I thought the RTC and jbe were hard wired to use a private IBM java so I did not think they would be affected.

Now, I can connect and log on to with a browser but it reports 
The server status cannot be retrieved.ID CRJAZ1505E
show details
and further down 
Jazz Team Server Location Connected to:
HTTP/1.1 503 Service Unavailable Server:Apache-Coyote/1.1 Content-Type:text/html;charset=utf-8 Content-Language:en Content-Length:1184 Date:Tue, 09 Dec 2014 03:23:33 GMT Connection:close
Version 5.0.1

Trying to connect to just fails

HTTP Status 404 -

type Status report


description The requested resource is not available.

Apache Tomcat/7.0.54

What did I break?

Restarting RTC and rebooting the server have no effect, I get the same result.

uninstalling the oracle Java 8 with apt-get remove does not change anything either

Ralph Schoon commented Dec 09 '14, 2:23 a.m.

As far as I can tell, the server has hardwired the JBE that ships. The Eclipse client as well, as far as I know.

I am not sure in which cases that could be overwritten without you knowing it. I have never experienced what you see.

Christopher Smith commented Dec 09 '14, 7:42 a.m.

 I'll be happy if someone can recommend something to "fix" my rtc server.

If RTC is "fragile", I will have a lot of trouble getting the rest of my company to start using it.

Krzysztof Kaźmierczyk commented Dec 09 '14, 8:10 a.m.

Hi Chrisopher,
I would recommend you looking into tomcat logs and jts.log file for any error messages there.

sam detweiler commented Dec 09 '14, 9:29 a.m. | edited Dec 09 '14, 9:31 a.m.

check the eclipse.ini/jbe.ini to make sure the IBM jvm is still specified.

notice that the IBM JVM uses IBM only parameters which will fail on the other jvms.

I have seen my ini files modified many times, and save a copy for when it happens again

One answer

permanent link
Christopher Smith (1825) | answered Dec 09 '14, 10:29 p.m.
edited Dec 09 '14, 11:11 p.m.
 I inspected the tomcat catalina.out and there were a BUNCH of "Too many files open" socket exceptions.

I recalled seeing in the installation instruction about setting the max open files. 

I did and I check to confirm that I did.

Anyway, they had a blurb about setting the limits in a shell and reindexing the DB.  So I did that.

ulimit -n 65536
ulimit -u 10000

It seems to have corrected my problem.  RTC seems to be running normally.

This is not a solution as I need to know why the global settings did not seem to be happy.

Donald Nong commented Dec 09 '14, 10:41 p.m.

You did not mentioned what the "global settings" are and how they are configured. The ulimit is definitely a prerequisite for installing CLM (I got the same error when using the default Red Hat configuration). You may want to verify how many files are opened when the problem occurs (or not occur).

Donald Nong commented Dec 10 '14, 1:22 a.m.

My comment was directed to your statement "this is not a solution as I need to know why the global settings did not seem to be happy". So unless you can explain in details what has been changed, no one can answer why.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.