It's all about the answers!

Ask a question

Issue with opening *mpp files using RAM


anoop mc (75010146205) | asked Sep 11 '14, 2:35 a.m.
Hi,

We have an issue while trying to open the .mpp files (which was created using MS Project 2007 or 2010) from RAM using Internet Explorer. It open as an unrecognized file format.

Below is the error message we are getting

ram_mime_issue

One suggestion we have is to  set the mime type in the config file to only download the file and not to attempt to open it in the browser

Let us know if this is a known issue or any workaround / fix is available.

RAM Version : 7.5.1.1 and WAS : - 8.0


Accepted answer


permanent link
Ary Zhang (2474) | answered Sep 11 '14, 9:52 p.m.
JAZZ DEVELOPER
Hi,
It should be Microsoft's function to open up mpp in IE.
I think you have to do some settings, such as lower the security of IE , add file association, set MIME type in WAS, etc...
Thanks a lot.
anoop mc selected this answer as the correct answer

4 other answers



permanent link
anoop mc (75010146205) | answered Sep 23 '14, 9:09 a.m.
 After making necessary changes . The server need to be rebooted.

permanent link
anoop mc (75010146205) | answered Sep 15 '14, 3:59 a.m.
Since we have WAS Integrated Console, As stated in the technote after adding the MIME type of extension mpp now it is working fine.

Having made the entry we have restarted the WAS Service from the Services Console.

was_mime_fix


permanent link
anoop mc (75010146205) | answered Sep 13 '14, 12:41 p.m.
Adding MIME type and restarting the WAS Service did not resolve the above issue.

Another suggestion came to us is to  disable the artifact browse function in RAM. So that users can download the MS Project Files locally and open.

Let us know if there is a way to disable the artifact browse function,

permanent link
anoop mc (75010146205) | answered Sep 12 '14, 1:24 a.m.
The link talks about the same - http://www-01.ibm.com/support/docview.wss?uid=swg21269129

For embedded WebSphere Application Server v6.1 or other WebSphere Application Server servers without an admin console:
1. Locate the virtualhosts.xml file in the folder
WAS_HOME/profiles/<profile name>/config/cells/<cell name>
2. MIME types are defined in the following XML format:
<mimeTypes xmi:id="MimeEntry_91" type="application/msword">
<extensions>doc</extensions>
<extensions>docx</extensions>
</mimeTypes>
Where "MimeEntry_91" is a unique identifier in the file.
3. Save the file.
4. Start the WebSphere Application Server server.

Your answer


Register or to post your answer.