It's all about the answers!

Ask a question

Anyone have problem with multi-select parameters in BIRT report (RTC 4.0.6) ?


1
1
Paul Rinaldi (31149) | asked Sep 03 '14, 4:23 p.m.
Our server was just upgraded to RTC 4.0.6 and we have one of many BIRT reports that were working fine before the upgrade.
One of the reports did not return any rows today.  Turns out that when all values of a multi-select parameter are selected, when you try to look at the value inside the parameter, it is empty.  As long as you don't select all values, it will be populated correctly.

Anyone experience this as well?

2 answers



permanent link
Neeraj Laad (324) | answered Nov 27 '14, 8:29 a.m.
Thanks for the info Rafik.

I've been wondering why some of our reports have stopped working after the upgrade and this atleast explains why and I can work around them.

That said I think this is a disruptive change. I believe users should be able to select none, few or all entries from a multi-select list and we should should filter results based on that for the report.

permanent link
Rafik Jaouani (5.0k16) | answered Sep 04 '14, 1:05 p.m.
JAZZ DEVELOPER
Hi Paul, this is an optimization we did in 4.0.6. We looked at all of our out of the box reports and we noticed that selecting every value really meant you do not want to filter on those. So the report should produce the same results as selecting no value. This simplified the generated SQL and resulted in faster running reports.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.