It's all about the answers!

Ask a question

Encrypted password is not working to connect to RTC

Penchala suman (461425) | asked Aug 01 '14, 5:43 a.m.
 I've encrypted password refereed to the below IBM site

 copied pass.txt to file to different location

when I try to access RTC and it is failing, something wrong with my command, can you please help.

lscm login -r -u cc-adm-xxx -P "C:\RTC_Password\pass.txt" -n buildlogin


error message:

Could not log in to as user cc-adm-xxx: CRJAZ0124

E The user name or password is invalid.

CRJAZ0124E The user name or password is invalid.

An error has occurred. Kindly check the log for more details.

2 answers

permanent link
Shashikant Padur (4.2k27) | answered Aug 04 '14, 12:02 a.m.
You can try the following:
Run 'lscm --config C:\RTC_Password login -r <repository Uri> -u <username> -c' which will prompt for the password and cache the password under C:\RTC_Password directory. Basically C:\RTC_Password will be considered as the scm cli configuration directory.
After that you can run all scm cli commands by specifying the --config option. For ex:
lscm --config C:\RTC_Password list workspaces -r <repository Uri>

or you can set the configuration directory as an environment variable: SCM_CONFIG_DIRECTORY=C:\RTC_Password and run the commands as usual: lscm list workspaces -r <repository Uri>

Penchala suman commented Aug 04 '14, 11:27 a.m.

I've tried your solution but still it is asking password, 

we are looking some command take password always from file or encrypt password to log in RTC, so that no one can know my password using my account. There is no really restriction my password while log-in RTC then run all other commands.
I've log in using your solution, first I've to provide password and then next time when i try to load workspace run some other lsm commands it has to take automatically my password. i don't think this solution will help us.

Shashikant Padur commented Aug 04 '14, 11:02 p.m.

I just tried this and it works for me.

Can you show the exact steps with the commands that you used?

permanent link
Robert Wen (690412) | answered Aug 01 '14, 10:00 a.m.
 The link to the encrypted password reference is for the Jazz Build Engine.  The SCM command line tool doesn't have a feature to encrypt the password.  

You could create a certificate so that you're not sending a cleartext password.  Details are at:

Hope this helps.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.