It's all about the answers!

Ask a question

Problem running Jazz Foundation Application SDK war samples

Lukas Steiger (3131625) | asked Jul 15 '14, 4:03 p.m.
Dear all

I have downloaded and installed the Jazz Foundation 5.0 zip pachage. Once setup and installed, I have downloaded the 'Application SDK' package from the Jazz Foundation downloads page. This package contains two sample applications (in the apps folder of the unpacked download), 'buildingblocks' and 'JFSExplorer'. I have properly placed the configuration files as well as the war files at the appropriate location. After (re)starting the server, I wanted to access the SCR of both applications.
https://localhost:9443/buildingblocks/scr --> successful :-)
https://localhost:9443/JFSExplorer/scr --> results in the error below

HTTP Status 403 - CRJZS0040E No REST service handler is registered for the following path: /scr.

type Status report

message CRJZS0040E No REST service handler is registered for the following path: /scr.

description Access to the specified resource has been forbidden.

Some more details
  • I faced the same error before while i created a self made jazz apllication, unfortunately, nobody could help me out there till now..., maybe because it was to specific, so I went on to find an example which is easy reproducable
  • I have assigned all available repository permissions as wll as the Rational Jazz Foundation - Foundation User license.
  • I did this installation on a PC where I've never installed anything related to jazz/ibm before, to make sure there are no side effects.
  • Due to the issue above, I could only register the buildingblocks application in 'register applications' of jts

It would be phenomenal if someone out there could point me in the right direction, I'm getting mad about this 403 error ;-|

Best Regards

Ralph Schoon commented Jul 16 '14, 2:55 a.m.

I have asked around. The examples are outdated and I could not find a resource that could look into this and updated them, unfortunately.

Lukas Steiger commented Jul 16 '14, 2:58 a.m.

 Hi Ralph

Well, that is sad to hear, but thanks a lot for asking around. 

Ralph Schoon commented Jul 16 '14, 3:21 a.m.

I tried the samples myself and I am exactly where you are, Lukas. Sorry.

Lukas Steiger commented Jul 16 '14, 3:33 a.m.

Do you have the source code for the buildingblocks application? As far as I can see, it is not included in the Application SDK package.

If you could provide it, I would be able to compare it to my own application, where i get the 403 error. I think the error might be caused by a new security feature which was implemented after they have created the Custom Application tutorial and the JFSExplorer app.

I'm talking about the following jars:

Ralph Schoon commented Jul 16 '14, 4:08 a.m.


I have the same access you have, pretty much. You could try to locate a JSF build as described in one of the tutorials and see if there is access to these JAR's. I am not sure about the path to the build results however.

Lukas Steiger commented Jul 16 '14, 4:16 a.m.

 Could it be one of these downloads? They seem to be only available to IBM folks. 

Ralph Schoon commented Jul 16 '14, 4:38 a.m.

I don't know. At this point we are down to trial and error, unless we find someone who is familiar with the code and can provide hints.

omar kabada commented Sep 24 '15, 10:20 a.m. | edited Sep 24 '15, 10:20 a.m.

 Hello Lukas.

Were you able to find the source of the error??  We are following the same tutorial for creating a custom app and we are stuck with the same error when we try to deploy our war file.   

Lukas Steiger commented Oct 06 '15, 2:39 a.m.

No, unfortunately not

showing 5 of 9 show 4 more comments

One answer

permanent link
Donald Nong (14.5k414) | answered Nov 12 '15, 5:34 a.m.
edited Nov 13 '15, 3:57 a.m.
The HTTP 403 error is expected because there is no /scr specified for this application. You should notice that there is no scr.xml included in the .war file. The file shows all the registered REST services:

The landing page should be https://<host>:<port>/JFSExplorer/explorer but I got a HTTP 401 error instead. Need to dig a bit deeper.

Finally make it work (with CLM 5.0.2). Steps below.
1. Deploy both the buildingblocks and JFSExplorer samples to Tomcat.
2. Start Tomcat.
3. Register buildingblocks to JTS.
4. Find out the OAuth consumer secret and key in or friends.rdf under server/conf/buildingblocks.
5. Modify the file server/conf/JFSExplorer/ to put the values found at the previous step.
6. Restart Tomcat.
7. Access https://<host>:<port>/JFSExplorer/explorer and the JTS login page should show up.
8. Log in as an existing JTS user, and the prompt will appear asking whether to allow collaborating with buildingblocks.
9. Answer Yes and the JFSExplorer page should appear.

More information about JFSExplorer can be found in the below Wiki page.

Your answer

Register or to post your answer.