It's all about the answers!

Ask a question

How to connect to the RM application using OSLC, distributed server installation.

Asaf Kivity (3311016) | asked Jun 17 '14, 11:57 a.m.
edited Jun 17 '14, 12:00 p.m.
We are trying to connect to the RM application using OSLC, failing with authentication problems.
Initially we tried using cUrl, later with JAVA, still no luck.
We are able to do it when the JTS server includes the RM application (This is our test env).
On our production environment, JTS and RM are installed on completely different servers.
When I try to complete example 3 from the OSLC LAB, it also fails on me, with this error:

    - X-Powered-By: Servlet/3.0
    - Location:
    - Content-Language: en-US
    - Content-Length: 0
    - Date: Tue, 17 Jun 2014 15:48:01 GMT
    - Server: WebSphere Application Server/8.0
Jun 17, 2014 6:48:03 PM org.apache.http.client.protocol.ResponseProcessCookies processCookies
WARNING: Invalid cookie header: "Set-Cookie: jfs-request-token-e9be36e0cc5844589ed44532ac4fcad8="8pKHbgOULLxeHkdqUoojJGaW4YD6YbO0OxkCEUo9g"; Version=1; Max-Age=600; Expires=Tue, 17-Jun-2014 15:58:03 GMT; Path=/rm". Unable to parse expires attribute: Tue
Jun 17, 2014 6:48:03 PM org.apache.http.impl.client.DefaultRequestDirector handleResponse
WARNING: Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm=}

How can I authenticate in this scenario?


One answer

permanent link
Donald Nong (14.5k414) | answered Jun 18 '14, 12:03 a.m.
By the look of it, you were using the wrong cookie - it appears that you used the cookie from the RM server to POST to the JTS server.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.