It's all about the answers!

Ask a question

Is there a way to query all plan of a given project area using REST API


Erwin Kunz (94686285) | asked Apr 17 '14, 11:46 a.m.
RTC 4.0.5

Is there a way to get all plan of a give project area using Rest API

I was able to query all plans by using
https://server/ccm/rpt/repository/apt?fields=apt/iterationPlanRecord/%28projectArea/%28name%29%29/

and I tried
https://server/ccm/rpt/repository/apt?fields=apt/iterationPlanRecord[projectArea/name=%27CLM%20Sandbox%27]/%28projectArea/%28name%29%29

to filter those belonging to Project CLM Sanbox

But then I get Error 500: CRRED8022E: Non Queryable Field: projectArea/name

do i something wrong, or is the REST API of apt not able to filter on ProjectArea

Thank you
erwin

2 answers



permanent link
Stephane Leroy (1.4k149) | answered Apr 23 '14, 12:21 p.m.
JAZZ DEVELOPER
Hi Erwin,

do you get any help (esp. from the 2nd URL) from the table provided in the document cited below:
http://sleroyblog.wordpress.com/2013/04/09/querying-rqm-40-through-oslc-and-rest-api/#cs_access_thru_rest ?

Regards,
Stéphane


Comments
Erwin Kunz commented Apr 24 '14, 8:28 a.m.

Salut Stéphane

I've seen your blog. Unfortunately it's RQM specific. The Jazz REST API and its behavior is very application specific. eg. filter on RRC does not work at all.

Unfortunately it doesn't help me further


Stephane Leroy commented Apr 24 '14, 9:00 a.m.
JAZZ DEVELOPER

Oups ! you're totally right. This was too RQM-specific...
Next time will spend some more time reading before I answer...


permanent link
Charlie Seo (22127) | answered Apr 18 '14, 3:48 a.m.
The first one should grab the project names only rather than plans. In order to filter the Reportable REST API, you need to comply with XPATH syntax.

The following syntax should return both project and plan name back. I found that /projectArea/name and /name (for plan) is located in the same level of xml node.

https://server:9443/ccm/rpt/repository/apt?fields=apt/iterationPlanRecord/(projectArea[name='JKE Banking (Change Management)']|(name))

Comments
Charlie Seo commented Apr 18 '14, 3:50 a.m.

Correction, not both project and plan but only plan names under the projectArea


Erwin Kunz commented Apr 23 '14, 5:59 a.m. | edited Apr 23 '14, 6:01 a.m.

Hi Charlie
I tried your query, and unfortunately this returns all iterations of the server :-(

the query to get the data is:
https://bt-clmserver01.hqs.sbt.siemens.com/ccm/rpt/repository/apt?fields=apt/iterationPlanRecord/projectArea/(name)|(name))

this returns
 
<iterationPlanRecord>
    <projectArea>
        <name>MNS-NG</name>
    </projectArea>
    <name>Documentation - MP1 - Inning 20</name>
</iterationPlanRecord>

so i tried to filter on first name without success.

than I tried just to filter on PA with
https://server/ccm/rpt/repository/apt?fields=apt/iterationPlanRecord[projectArea/name='MNS-NG'] which ends with Non Queryable Field: projectArea/name

I 'm lost. Any idea?

erwin

Your answer


Register or to post your answer.