It's all about the answers!

Ask a question

How do I debug a custom RTC plugin?


Surender Biyyala (403748) | asked Mar 08 '14, 1:50 p.m.
edited Mar 08 '14, 5:26 p.m. by Geoffrey Clemm (30.1k33035)
 Hi,

I developed one RTC Plugin and I want  to debug it but somehow I followed the procedure given in the following link

https://www.ibm.com/developerworks/community/blogs/extendingrtc/entry/preparing_for_extending_3of3?lang=en

note: The plugin is deployed onto RTC Server and is working fine.
          I`m able to debug IBM RTC plugins but not the source code I wrote for my plugin

please suggest me on this.

Thanks
Surender

Comments
sam detweiler commented Mar 08 '14, 9:04 p.m.

If you put a stop in your source for the debugger.. you should get prompted for the source location..

I think I needed to use the eclipse with the source project as the debugger platform too.

to prevent a deadlock, I use one eclipse to cause the operation, and a different eclipse to develop and debug the plugin.

I usually do not use the web UI to cause the operation.

Accepted answer


permanent link
Ralph Schoon (63.2k33646) | answered Mar 10 '14, 4:32 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Please consider reading https://jazz.net/library/article/1000 about how to debug if you deployed on Tomcat. If you deployed on WAS, I assume there are similar approaches.
Surender Biyyala selected this answer as the correct answer

One other answer



permanent link
Charlie Seo (22127) | answered Mar 09 '14, 7:22 p.m.
Not only using break in the debugger but also considering creating own exception to catch any issue would be a good idea.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.