It's all about the answers!

Ask a question

Problems with fetching source code (RTC and BuildForge integration)


Saurabh Jain (568) | asked Feb 10 '14, 5:50 p.m.
edited Feb 10 '14, 9:55 p.m.
I am following this tutorial and as a first step for that ,I have created a 1 step project in BF console to fetch the code from RTC repository and store somewhere it on the agent.

https://jazz.net/library/article/607

Below are the details for BF and RTC.
  1. RTC Server running on : 8.X.X.1
  2. BF Server running on :8.X.X.2
  3. BF agent running on : 8.X.X.3

My RTC repository has 2 projects Customer-Application and Customer-Test.

In my BF project I am trying to fetch the source code of both the projects on the bf agent.

I have provided this command for my first step

.source JazzJBE

This step has been executed successfully but when I checked the location that I have mentioned in the Server configuration , it is not fetching any source code.

Location given in server config - /home/user2/tmp

And at this location - it is creating this directory structure

/home/user2/tmp/Customer-Application/BUILD_22

and inside BUILD_22 , it creates a folder workspace and which contains some eclipse jars.

I didn't see any exception in the logs, but at the end it is throwing some warning , that I am not able to resolve.

Note : I am running this project from BF console itself (not eclipse RTC client)

This is the snippet of the log where I am getting warning.

272    2/10/14 4:44 PM        EXEC    Java Version:
273    2/10/14 4:44 PM        EXEC    OpenJDK Runtime Environment (version 1.6.0_24-b24)
274    2/10/14 4:44 PM        EXEC    Engine Bundle Version:
275    2/10/14 4:44 PM        EXEC    com.ibm.team.build.engine, 3.0.500.v20130502_0139
276    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:23 [Jazz build engine] Searching for buildResultUUID=default
277    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:23 [Jazz build engine] The -noComplete argument was specified. The build result will not be completed by JBE.
278    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:23 [Jazz build engine] Building only the specified participants: "[com.ibm.team.build.jazzscm]"
279    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:24 [Jazz build engine] Not using a proxy to reach https://xx.yy.com:9443/ccm/
280    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:26 [Jazz build engine] CRRTC3526W: Warning: The build engine is either not in the repository, or it cannot be accessed by the following user: "saujain". The UUID of the build engine is "default".
281    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:26 [Jazz build engine] No requests found.
282    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:26 [Jazz build engine] Exiting JBE after completing single build request, RC=1.

283    2/10/14 4:44 PM        EXEC    CRRTC3529W: The execution of Jazz Build Engine completed with a non-zero return code (RC=1).
	
	
	
	
	
	

284    2/10/14 4:44 PM        EXEC    ENDBFBomPlaceholder1392068672357
285    2/10/14 4:44 PM        EXEC    end [/home/user2/tmp/Customer-Application/BUILD_22@RMV-EAP-SPR-D01]
286    2/10/14 4:44 PM        RESULT    0
287    2/10/14 4:44 PM        INT    CRRBF0878I: Env Group '[ADAPTOR]' variable 'Last_Run' set to [].
288    2/10/14 4:44 PM        INT    Finished Block Processing.
289    2/10/14 4:44 PM        MJC    CRRBF1576I: Call JazzJBE adapter and fetch source code completed (0)
.

Any help is really appreciated.

My assumption is that , if everything goes fine i will have my project copied into this location

/home/user2/tmp/Customer-Application/BUILD_22 from RTC. Is it a correct assumption ?


2 answers



permanent link
Don Yang (7.7k21108138) | answered Feb 11 '14, 12:36 a.m.
The warning:
280    2/10/14 4:44 PM        EXEC    2014-02-10 16:58:26 [Jazz build engine] CRRTC3526W: Warning: The build engine is either not in the repository, or it cannot be accessed by the following user: "saujain". The UUID of the build engine is "default".

suggests you did not request the build through Eclipse client? Supposed you have followed everything in the article, can you try build request from Eclipse client?

Comments
Saurabh Jain commented Feb 11 '14, 11:19 a.m.

Hi Don,

I have tried from the eclipse also , and created a build engine there , but still I am getting the same error.

I checked the build engine exists in the RTC repository and I  also checked my user id  has the permission to request new build permission.

Can you please advice what might be causing this ?

Thank you


Don Yang commented Feb 12 '14, 12:18 a.m.

We see similar problem when engineUUID variable is not configured properly. Build Forge environment may not be synced to populated the right engineUUID, or the user is not the member of the RTC project, password is wrong etc.
It is also reported in lower version of RTC(3.0.x) or BF(7.1.x) could have similar problem and upgrade to v4.0.1 or higher(RTC) and BF to 8001 helps in some cases.

The conditions we set if that you followed everything properly in https://jazz.net/library/article/607 , if there is any configuration not done properly, it is likely to throw similar error. We can only provide some general scenarios/cases we see before for you to check with as above, it may require more detailed investigation if you have checked everything and don't think any applied. In that case, please contact support and some debug trace would need to collect to investigate.


permanent link
Deepali Deshmukh (8913759) | answered May 26 '16, 1:30 a.m.
 Hi saurabh,

I am facing the same issue. Is this program solved.If yes then can you please share your findings to resolve this issue .

Your answer


Register or to post your answer.