It's all about the answers!

Ask a question

Get the Review from OSLC (Rest) from Rational Requeriments Composer

Lucas Marinoto (323) | asked Jan 20 '14, 12:44 p.m.

I am trying to get the revisions from OSLC from RRC, but I am able to return just one Review, i would like to get all review from RRC. Is it possible?

Now I am using this URL:
I already tried without ResourceURI but didn´t work.

Another question: Have any way to get the ResourceURI from review of the link artefact ?. For example:

I am using the URL: to get some informations about the requeriment, but don´t have any information about the ResourceURI from my review. how I can know which review this artifact is linked?


Accepted answer

permanent link
Charlie Seo (22126) | answered Jan 20 '14, 5:53 p.m.
I think the entry point of the review resource has defined under rootservices. It seems a generic API - https://[SERVER_NAME]:9443/rm/reviews you can use.

I also found that this REST API feed requires private head so make sure you add this in

DoorsRP-Request-Type : private

It does not filter by a project area but cross-project so you might need to filter using project ID if you want a project specific one.

Lucas Marinoto selected this answer as the correct answer

Lucas Marinoto commented Jan 21 '14, 7:07 a.m.

  Hi Charlie,

Thanks very much for help me.

I used the url and the header name: DoorsRP-Request-Type Value: private and now get all the reviews.


2 other answers

permanent link
Ahmed Omair (4422) | answered Feb 01 '17, 7:25 a.m.

 @Charlie Seo In REST-API i am able to get all reviews of the project using header: DoorsRP-Request-Type Value: private

However when i pass the header in the request through java code i get Error 403: forbidden.
<html><head><title>Error 403: Forbidden</title></head><body><h1>Error 403: Forbidden</h1><p>CRRRS4142E  getInternalRequestHandlerService(context) returned null. This error used to report &#039;The requested service requires a private header&#039;.<hr><i>Requirements Management/4.0.7</i></p></body></html>

Any ideas what can be the probelm?

permanent link
Chrisitan Bongard (11) | answered Mar 03 '15, 4:30 p.m.

I also tried to get the reviews via the following request:

But I only got the following response:
<?xml version="1.0" encoding="UTF-8"?>
<ds:dataSource xmlns:rrmReview="" xmlns:reviewParticipant="" xmlns:reviewComment="" xmlns:reviewArtifact="" xmlns:review="" xmlns:rdf="" xmlns:history="" xmlns:h="" xmlns:ds="" xmlns:attribute="" vMinor="20" vMajor="40" rrm:totalCount="1" xmlns:rrm="" appId="RRC"/>

There is no content. What do I do wrong?

Your answer

Register or to post your answer.