It's all about the answers!

Ask a question

Restricting user to modify priority stops them from closing a Task

Jason Chan (379) | asked Jan 10 '14, 11:40 p.m.
Similar to below thread. 

I tried to restrict the team member role to modify the priority of a work item by removing the permission to "Modify the work item's priority". While that works as it named, it also creates the problem that my team has loss the ability to close a "Task" item. When they do that, below error is shown

"Permission Denied. You don't have permission to perform the following actions: modify/resolutionDate."

P.S. Am using

Susan Hanson commented Jan 11 '14, 12:46 a.m.

I'm not seeing the same that you are, although I didn't exactly do the same thing you did.  We are also on 

On my test server, I have a custom work item (which includes the built-in priority attribute).  I modified the permissions for Everybody so that they do NOT have permissions to change the priority attribute.  I then opened one of my custom work items and canceled it.  It worked fine, no errors.

One answer

permanent link
Don Yang (7.7k21114139) | answered Feb 12 '14, 1:58 a.m.
I tested with 4.0.1 and did not see the same behavior. I could not find any existing defect between the version 4001 and 401 on this error.
Are you using the standard RTC Scrum or Formal template or not? Do you have any custom attributes in your task workitem and whether there is any dependency between any attributes? Is there any operation behavior configured against the action on the workitem? If you check with the permissions in the admin page, do you see the permission modify/resolutionDate or similar is allowed or not?

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.