It's all about the answers!

Ask a question

RQM 'TER Listing' Report not pulling latest Iteration Result

Pragati Shrestha (27269) | asked Jan 10 '14, 3:11 p.m.

I have a Test Plan with 209 Test Cases, out of which 4 are failed, 11 Blocked, and 194 Passed Test Cases.

The Test Cases might have been executed more than once, and everytime we execute test cases, we generate new test case execution record with different Iterations.

Many test cases failed before might have been re-executed with new iteration and hence passed.

In the TER Listing Report, I select the corresponding Test Plan and 'Yes' for Most Recent Iteration Only criteria. But, on the contrary to the correct result, it shows 92 Failed Test Cases.

What is the best way to get the latest result of the execution record? Am I doing something wrong over here?

Sunil Kumar R commented Jan 13 '14, 10:06 a.m.

Hello Pragati, did you try looking at the report with 'NO' selected for 'Most Recent Iteration only'?

I see a lot of difference (expected # of entries) in JKE Banking (of the Money that Matters sample) project area -> TCER Listing report with 'YES' | 'NO' selected for the filter mentioned above.

Have you tried checking if additional filters need to be selected? perhaps the other option to include 'Child Test Plans?'

Best Regards, Sunil

Vidya Malkarnekar commented Jan 13 '14, 4:25 p.m.

Hi Pragati,

What is the RQM version?
Have you taken a look at the report output to see what iteration the failed TERs belong to ? That may give you an idea on what's going on.

2 answers

permanent link
Clara Forero (6212) | answered Jan 28 '14, 12:33 p.m.
In the TCER Listing (Live) report, if the "Most Recent Iteration Only" parameter is set to "Yes", it should display only the latest record (based on the dates of the iteration) for each Test Plan, Test Case and Test Environment combination.  If this is not the result you are seeing in the report, please create a defect and we'll investigate.  Thanks!

permanent link
Michal Steinberger (181828) | answered Dec 23 '14, 3:32 a.m.
edited Dec 23 '14, 3:53 a.m.

I'm dealing with the same problem on version 4.0.6.
Something changed?
i run it with "yes" for recent version, one tc is return right but another return with previous iteration..


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.