It's all about the answers!

Ask a question

Cannot edit timeline with non-english locale

Fredrik Jägare Lilja (6135) | asked Dec 18 '13, 5:33 a.m.
edited Dec 19 '13, 11:09 a.m.

I've created a couple Sanbox-project for getting to terms with JazzHub.

But, I'm having some trouble editing the timeline. When created I cannot edit it at all. Reading some posts I can see that I have to use the WebUI to edit the timeline. Though when I'm trying to add a Sprint to my timeline nothing happens. Also, I cannot change dates, names or anything in the timeline. Furhtermore no Sprint in my timeline is marked as active.

This is really frustrating, what am I doing wrong?

2 answers

permanent link
Fredrik Jägare Lilja (6135) | answered Dec 19 '13, 10:57 a.m.

Seems like Swedish locale is the problem.

Using Swedish locale

Using English (US) locale

This is a defect in my opinion, I'm happy to contribute to the defect report.

Lauren Hayward Schaefer commented Dec 19 '13, 11:47 a.m.

Thanks for the detailed video!  It will be incredibly helpful.  I've opened| to track this work.  Please add anything I missed.

permanent link
Lauren Hayward Schaefer (3.3k11727) | answered Dec 18 '13, 6:37 a.m.
Hi Fredrik,

I'm sorry this has been frustrating for you!  Note that you must be the creator of a project to edit the timeline.  Here are the steps to edit your timeline:
  1. Log in to
  2. On the My Stuff page, click on a project you own
  3. On the project home page, there will be a Create Timeline button or an Edit Timeline button that you can click
  4. Use the dialog to create or edit your timeline

JazzHub automatically updates the current sprint for you whenever you create/edit your timeline and every night at midnight.

Fredrik Jägare Lilja commented Dec 18 '13, 6:43 a.m.

Hi, thanks for answering.

However, I've already did this in the way that you're suggesting.

For all my three projects (that I created and own) all Sprints are marked as "ended". When I bring up the Edit Timeline-form, the Save button never gets enabled, nor is any new Sprint added when I press Add Sprint.

I would happily provide you with screenshots/movie although a cannot post them in this forum.

Lauren Hayward Schaefer commented Dec 18 '13, 6:48 a.m.

Hmm... I just tested in FF 25, IE 9, and Chrome 31.  In all 3, the Save button was enabled as soon as the dialog opened, and clicking Add Sprint worked.  What browser are you using?

Fredrik Jägare Lilja commented Dec 18 '13, 3:53 p.m.

I've tried in Chrome 32 and IE 9. Adding a screencast to show you. Note that clicks are not visible in this screencast.Screencast

Lauren Hayward Schaefer commented Dec 19 '13, 7:38 a.m.

I noticed that your browser is not set to English. Perhaps something is going wrong with the date translation.  What language are you using? 

I also noticed that the end dates are not set for the iterations, which I have never seen before. Can you try adding end dates and see if that enables the Save button?

Can you also try accessing your project home page with "?debug=true" at the end of the url (so it would look something like  Then open your browser's console and try editing the timeline.  I'm curious if you're getting any javascript errors.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.