It's all about the answers!

Ask a question

How can we work off-line with the RTC Visual Studio Client?


Eddie Breeveld (6112330) | asked Dec 12 '13, 11:40 a.m.
edited Dec 12 '13, 11:41 a.m.
If the RTC server is down, or we do not have a network connection for other reasons, it is impossible to work with Visual Studio 2010 if used with the Jazz RTC (4.0.4) source control client: It takes about 5 minutes for Visual Studio to start before giving an error message that the server is not available, then when choosing to continue and opening a solution, it is taking about 5 minutes to load each project. As we have 30 projects in our solution, the time taken before we can start working off-line is impossibly long.

2 answers



permanent link
Sreerupa Sen (1.0k4) | answered Jan 02 '14, 11:47 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
 Hi Eddie,
    That's surprising - that VS takes so long to load projects or to start up when your server is offline. I have auto-login set to true and when VS starts up it tries to login to the server and fails and is a bit slower than the normal login situation, but I've never seen it to take 5 mins! I have 86 projects in my VS 2010 solution (the entire source code for RTC VS Client) and I haven't seen projects taking 5 mins to load either.

The login timeout (again configured through Repository Properties) is 6 minutes by default - I'm wondering if your server was not responding  when you saw the 5 minutes delay - which is different than being down - if the server's slow the client maybe waiting for the http response. Would you have the logs for it that we can look at? If you do it'd be great if you create a work item on jazz.net and attach the logs.

    I'm glad switching off auto-login solved your problem - the client doesn't turn user controllable options off or on automatically so you'd have to do it manually. 

Cheers
--Rupa
RTC Clients Team

permanent link
Eddie Breeveld (6112330) | answered Dec 16 '13, 9:49 a.m.
edited Dec 16 '13, 9:54 a.m.
(With thanks to Ken McRae)
Switch off the auto-login on startup solves the problem:
  1. Right click on the username under the Repository Connection in the Team Artifacts window
  2. Select Properties
  3. Turn off Auto-login at startup.
This is a bit clunky, but it does work.  I would have thought that the RTC plug-in could have done this automatically.

Your answer


Register or to post your answer.