It's all about the answers!

Ask a question

Using RTC 3.0.1, does "lscm move" work to move a file to a different subfolder?

Donna Thomas (14122548) | asked Sep 27 '13, 2:04 p.m.
Using RTC 3.0.1, does "lscm move" work to move a file to a different subfolder? I keep getting a error that the folder I'm in while running lscm (a layer or two under the Jazzhome folder) is not a shared folder or resource. So, I shared it, and it didn't work. I shared all the folders from the root down to where I was. Didn't work. The file I want to move is definitely in a local sandbox. (I'm trying to keep the history of the file changes. I don't want to simply recreate it in the destination and delete it from the source.)

So, I am trying to find out - is there any way to move a file and retain its history?

Tim Mok commented Sep 27 '13, 3:07 p.m.

Sorry, I misinterpreted your question. Yes, it will move a file and retain history. At this point, it's difficult to understand what went wrong in your case. It would be useful if you provided the folder layout of what's already been shared, what you have loaded in your sandbox, and what command you tried to move the file.

Donna Thomas commented Sep 27 '13, 3:26 p.m.

ok - I'm running the command from (RTC_eclipse is my local jazzhome):

I have several real files to move, but this is a test command that I tried...
lscm move -u <username> -P <password> "\RTC_ws\Sandbox\Donna_test_instructions_v1\Donna_docs_for_test\Env_Docs\d1.txt" "\RTC_ws\Sandbox\Donna_test_instructions_v1\Donna_docs_for_test\Env_Docs\test\d1.txt"

I have tried this with and without the -u and -P. Also, I've tried with and without the quotes.

Every time I get the same response:
Could not initialize data area:
The directory "C:\RTC_eclipse\scmtools\eclipse" is not shared. This command must be run on a descendant of a directory that has either been shared or loaded.

One answer

permanent link
Tim Mok (6.6k38) | answered Sep 27 '13, 2:32 p.m.
You can find the answer in those questions that ask the same thing.

Donna Thomas commented Sep 27 '13, 3:02 p.m.

The first one is not clear at all... move the file to its own "project" - is that project area? If so, then how do you move a project area into a component? That answer doesn't make sense.

The second link seems to answer the same question again. Of course, it does make the first one more clear, although still not answering my question.

Neither addresses moving a file within a component, from one subfolder to another.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.