It's all about the answers!

Ask a question

Has anyone tried RTC 4.0.x p2 client installation on RAD 9.0 on linux?

Jack Goldstein (3658) | asked Sep 25 '13, 5:53 p.m.
My colleague tried to load the p2 client into his RAD 9.0 Eclipse in many different ways (e.g. different machines, different versions of RTC p2 client) but it never worked.  That is, the install proceeded smoothly, with no errors, and afterwards, the  list of installed components seemed right but the "Work Items" perspective and other things that would normally be added were not present.

I did what seemed like identical steps on my Windows 7 box and had no problems.  Later, he downgraded to RAD 8.5 on Linux and had no problems with that.

Does anyone know what could be wrong?

Jack Goldstein

Accepted answer

permanent link
Lara Ziosi (33811112) | answered Sep 26 '13, 5:11 a.m.
Hi Jack,

Could you also please clarify what exact version of the RTC client you are trying to install on RAD v9?

RAD v9 is based on Eclipse 4.2, and it is only compatible with the "RTC Client for Eclipse 4.2", which started to ship in RTC 4.0.3 and is also available in 4.0.4. Be aware that these versions of RTC also have another version of the client, applicable for earlier Eclipse versions.

You can generate the compatibility report from here:
Choose: Prerequisites
Product/prerequisite combination
enter as product Rational Application Developer for WebSPhere v9
enter as prerequisite Rational Team Concert and select all versions
You will see that only RTC 4.0.3 and 4.0.4 are compatible with RAD v9.

Thank you and regards, Lara
Jack Goldstein selected this answer as the correct answer

Jack Goldstein commented Sep 27 '13, 4:56 p.m.

Lara, thanks for the info.  I think that my colleague tried many different versions but our server is at 4.0.1 and from what I remember, a 4.0.3 client won't work with a back level server so the problems I described are with 4.0.1.

Strangely, I was able to apply the 4.0.0 client on my RAD 9 on Windows 7 and that worked, or at least has not shown any problems so far, but I'll still upgrade to 4.0.3 when I'm able.

One other answer

permanent link
Eric Jodet (6.3k5111120) | answered Sep 26 '13, 2:08 a.m.
 Hello Jack,
for the non-working install, may you please check the workspace's .log and copy the content here?
location is : <workspace_dir>/.medatadata/.log


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.