It's all about the answers!

Ask a question

RTC support for Eclipse 4.3


Bruce Skingle (2345) | asked Sep 25 '13, 9:28 a.m.
edited Sep 25 '13, 10:01 a.m. by Krzysztof Kaźmierczyk (7.4k372103)

1. Is there a planned date for RTC support for Kepler?

2. What is the general position on keeping up with new Eclipse releases?

Accepted answer


permanent link
Tim Mok (6.6k38) | answered Sep 25 '13, 9:39 a.m.
JAZZ DEVELOPER
270785: [CCM] Support Eclipse 4.3

There's a plan item for Eclipse 4.3 support. Personally, I've also been using Eclipse 4.3 by installing with the p2 repo into Eclipse 4.3. It works well enough but that doesn't mean there may be bugs that I haven't encountered.
Bruce Skingle selected this answer as the correct answer

One other answer



permanent link
Fred Rowe (611) | answered Mar 27 '14, 9:01 a.m.
Tim, when you say you been able to get it to work by installing with p2 repo into Eclipse 4.3, isn't that a slightly different config that the original question? Bruce asked specifically about Kepler (which is based on 4.3) but includes a number of other tools.  I'm asking because when I attempt to install RTC 4.0.5 client from p2 repo into Kepler, I get:
Cannot complete the install because one or more required items could not be found.
  Software currently installed: Eclipse IDE for Java EE Developers 2.0.1.20130919-0803 (epp.package.jee 2.0.1.20130919-0803)
  Missing requirement: JavaScript Development Tools 1.5.1.v201307171524-7H7FFhVFC7sResSz-gpggbs (org.eclipse.wst.jsdt.feature.feature.group 1.5.1.v201307171524-7H7FFhVFC7sResSz-gpggbs) requires 'org.eclipse.wst.jsdt.core [1.3.0.v201308282108]' but it could not be found
  Cannot satisfy dependency:
    From: Eclipse IDE for Java EE Developers 2.0.1.20130919-0803 (epp.package.jee 2.0.1.20130919-0803)
    To: org.eclipse.epp.package.jee.feature.feature.group [2.0.1.20130919-0803]
  Cannot satisfy dependency:
    From: Java EE IDE Feature 2.0.1.20130919-0803 (org.eclipse.epp.package.jee.feature.feature.group 2.0.1.20130919-0803)
    To: org.eclipse.wst.jsdt.feature.feature.group 0.0.0

Comments
Tim Mok commented Mar 28 '14, 1:48 p.m.
JAZZ DEVELOPER

You can try checking your update sites in the preferences and see if the Eclipse repositories are there. Those dependency errors are on Eclipse features and p2 might not be able to find them because the Eclipse repositories are missing.

Also, I was installing RTC 4.0.6 into Eclipse 4.3. I'm not sure if I've tried RTC 4.0.5 with Eclipse 4.3 but more recent versions have had fixes to improve support for Eclipse 4.x.


Fred Rowe commented Mar 29 '14, 7:41 a.m.

The problem was solved when I went from Kepler SR1 to SR2.  I can now install RTC 4.0.5 client with no errors.

Your answer


Register or to post your answer.