It's all about the answers!

Ask a question

Synchronize attributes works in Eclipse client but not web UI

Daniel Vaganek (7358) | asked Sep 24 '13, 9:23 a.m.
RTC 4.0.1
I searched here and have seen similar problem, but no solution.
I added a new drop down (simple Unassigned/Yes/No) attribute to existing work items and updated the work items in Eclipse (Synchronize Attributes).  In my query in Eclipse I see the default result (Unassigned) of my new attribute.  Using Eclipse client I see the new attribute in the UI.  In Eclipse I can create queries using the new attribute and can also put it the column display.  But, in the web UI I can not see the new attribute as an available attribute to use in a query condition not can I select it in a column display.  In my query I created in Eclipse I can see the new attribute in the column display, but it does not appear in the query result set.  If I open an existing work item in the web UI I see the new attribute, but it is greyed out.  Refreshing the browser page does nothing.  I flushed the browser cache, no change.  I re-booted my machine, no change.  I tried two different browsers (Firefox and IE) no change.  I have added new attributes before with no problem.  What is going on here?  Will a server re-boot correct this? 

Daniel Vaganek commented Sep 24 '13, 9:40 a.m.

Tried using Chrome, no change.

2 answers

permanent link
Daniel Vaganek (7358) | answered Sep 25 '13, 8:45 a.m.
Re-booting the Jazz server appears to have corrected this.
Not the best answer as I would like to know why it wouldn't work otherwise.

permanent link
Ralph Schoon (62.7k33643) | answered Sep 24 '13, 10:12 a.m.
I think, you have to add a presentation for the attribute, to see it in the Web UI. Only the Eclipse UI shows the attributes that have no presentation.

Daniel Vaganek commented Sep 24 '13, 10:34 a.m.

Thanks Ralph,
I do have a presentation for the attribute.  I can see the attribute, but it is greyed out.

Ralph Schoon commented Sep 24 '13, 10:45 a.m.

Daniel, I have seen this only in the case, where the presentation was available but the specific work item was not synchronized and did not have a value for the attribute. Can u try to synchronize again? Do you see a value in the same work item in Eclipse?

Daniel Vaganek commented Sep 24 '13, 10:48 a.m.

<presentation attributeId="" kind="">
     <property key="readonly" value="false"/>
     <property key="labelVisible" value="true"/>

<customAttribute id="" name="Reference Data" type=""/>

Daniel Vaganek commented Sep 24 '13, 11:39 a.m.

Thanks again Ralph,
I have synchronized a few times actually.  I do see the value in the Eclipse client and it is editable, just not the web UI.  If I try the same work item I get different result.
I am going to bounce the Jazz server tonight and see what happens.

Daniel Vaganek commented Sep 24 '13, 11:43 a.m.

I should add that if I use the 'Check attributes usages in repository' link I get errors.
Maybe this is the problem? 

Error running operation 'Validating Repository'

CRJAZ0368I A SQL query failed to execute properly on the server.
   stmt = select COUNT(distinct t1.ITEM_ID) from MODEL.WORK_ITEM t1 where ((t1.PROJECT_AREA_ITEM_ID = ?) and 
   exists (select 1 from MODEL.WORK_ITEM_ITEM_EXTENSIONS x1 where t1.ITEM_ID = x1.JZ_PARENT_ID and x1.KEY_COL = ?) and  ...

(truncated due to too many characters to post)

Ralph Schoon commented Sep 24 '13, 11:47 a.m.

That is odd. Maybe, but if you look at the same item in Eclipse and the Web UI I won't expect a difference.

Do you have a lot of items to synchronize? There was a post about a timeout that could get you and that you could expand, if I remember correctly. If you have a lot of items, you can also try to use this small tool:

Daniel Vaganek commented Sep 24 '13, 1:00 p.m.

Odd indeed, especially since I'vd done it before with this project.  There are only 276 work items to synchronize.  Don't think that's the problem as the attribute shows up in my Eclipse query result.  Tried synching a few times.  Odd that it works in Eclipse as expected, but not web.  I'm new to RTC and don't know Java, but if I can find the time I would like to give your tool a shot.
Thanks again!

Dinesh Kumar B commented Sep 25 '13, 5:31 a.m. | edited Sep 25 '13, 5:32 a.m.

Hi Daniel, if you are v4.0.3 and working with SQL Server and have quite a few custom attributes, you are possibly experiencing the sync failure due to a known defect :
MS SQL Error while Checking Attributes Usage in the Repository (280184)

You may want to add your notes to the defect and track the status using the link above

and so I would want to try with the tool from Ralph's post.

Daniel Vaganek commented Sep 25 '13, 8:44 a.m.

Thank you, but we are on 4.0.1 using DB2.

showing 5 of 9 show 4 more comments

Your answer

Register or to post your answer.