It's all about the answers!

Ask a question

How to add a custom ant script to RTC build engine

Tao Weng (7824) | asked Sep 19 '13, 4:59 p.m.
retagged Sep 19 '13, 9:20 p.m. by Nhi P Ta (18841018)

I'm having trouble adding my custom ant script task to RTC build engine.

In RTC Eclipse Client, I created a plugin with a custom ant task class extending  I exported the plugin into jar. I put the jar in RTC Eclipse Client dropins folder. I launched RTC Eclipse Client and could use the custom ant task without any issue.

However, I then tried to put the same jar into RTC build engine plugins directory. jazz\buildsystem\buildengine\eclipse\plugins.

Then I tried to access the custom task with RTC build engine. I consistently got an error message saying the task class can not be found.

2013-09-19 16:13:15 [Jazz build engine] running on host: TP-WENGT

2013-09-19 16:13:15 [Jazz build engine] Should build occur?

2013-09-19 16:13:15 [Jazz build engine] Yes: Always build a user initiated request.

2013-09-19 16:13:15 [Jazz build engine] Invoking build participant ""

Unable to locate tools.jar. Expected to find it in C:\Program Files (x86)\IBM\Java60\lib\tools.jar

Buildfile: C:\work\runtime-EclipseApplication\P1\anttask.xml


C:\work\runtime-EclipseApplication\P1\anttask.xml:3: taskdef class <MY_CUSTOM_ANT_TASK_CLASS_NAME> cannot be found

Total time: 0 seconds

Build failed. Exit value was 1.

Marek Siekierski commented Sep 20 '13, 12:03 p.m.

Hi Tao,

Does the RTC build engine contain any white spaces in its path?

One answer

permanent link
Tao Weng (7824) | answered Sep 20 '13, 1:46 p.m.
I spent sometime debugging the issue and found out that it was a packaging issue. I got it working now. Thanks.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.