It's all about the answers!

Ask a question

Project explorer in RTC not showing anything?

Akhil Jain (41176) | asked Sep 13 '13, 10:55 a.m.
I have been using RTC for a while as document repository.  In the Project Explorer view, it will show me all the directories and files (just like windows explorer).  I just got a new laptop and moved all my directories and files to the new laptop.  I also reloaded "load as..." the components I had in my repository workspaces to the new directory structure I have.   All that works fine including the sync with the server and able to check-in and check-out the files.  The only thing not working is the project explorer.   I do not see anything over there.  It is blank.  How can I have it show all the directories and files that have been checked into RTC?

Marek Siekierski commented Sep 13 '13, 4:32 p.m.

Hi Akhil,

Project Explorer will show only Eclipse projects if I'm not mistaken. You will have to import existing projects.

Akhil Jain commented Sep 13 '13, 4:46 p.m.

Not really sure what that means.  My repository is loaded so I can see the workitems.  I can also see the documentation components I have where we store project documents.  I am able to sync with the server.  So all that works already.  The only thing is not be able to see the files in project explorer.  What import would I need to do for that?

Accepted answer

permanent link
Parker Dunton (4064) | answered Sep 13 '13, 7:38 p.m.
Try File > Import... > Existing Projects into Workspace
Akhil Jain selected this answer as the correct answer

Akhil Jain commented Sep 14 '13, 5:51 p.m.

That worked.  Awesome.  Thanks.

2 other answers

permanent link
Geoffrey Clemm (30.1k33035) | answered Sep 13 '13, 11:04 p.m.
The Project Explorer is an Eclipse view, for viewing Eclipse projects.   You have to tell your instance of Eclipse what projects you want to be working with, and you do so by "importing" those projects into Eclipse.   The Eclipse RTC plugin can help you out in that regard, if you use one of the variants of the RTC "load" command that says "Find Eclipse Projects" (then RTC will automatically do the "import" for you).   The "Load As" command you used must not have been one of the "Find Eclipse Projects" variants ... so you will need to either do the import yourself, or unload your workspace, and then load it again with a "Find Eclipse Projects" variant of the Load command.

permanent link
Ashley Clementi (111) | answered Oct 25 '15, 9:49 p.m.
Worked for me. In my eclipse it was located at File > Import > General > Existing Projects into Workspace

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.