It's all about the answers!

Ask a question

Getting exception on ITeamRepository.login() method - Client and server versions do not match.


Joe Celi (1389) | asked Sep 13 '13, 8:17 a.m.
My code is running with the 4.0.2 SDK and the server is running 3.0.1.3

What can I do to get around this exception.  Since my code is running with an SDK level that is above the server level I would have expected the SDK to handle the backwards compatibility.

I'm hoping that I do not have to find and old SDK and use those jar files in my JVM.

One answer



permanent link
Kevin Ramer (4.5k8184200) | answered Sep 13 '13, 9:57 a.m.
edited Sep 13 '13, 9:59 a.m.
Historically, clients haven't been compatable, but upward compatable was added circa v3.  That means that one can access a higher version server with a lower version client, but not vice versa.  You'll need the v3 SDK.

https://jazz.net/library/article/832  has details.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.