It's all about the answers!

Ask a question

Websphere 6.1 issues


derek cheng (46121) | asked Feb 02 '09, 9:47 a.m.
I'm having trouble with a fairly standard configuration of websphere. We're using bluegroups, LDAP and websphere 6.1.

I've gotten almost everything working, but I'm still having two issues.

  1. Every user has to authentication twice. First at the /jazz URL and then at jazz/admin or jazz/web depending on their user type.
  2. We have a floating license and are using a floating license server (localhost:9080). It worked fine when I first configured it, but now when you try to load up the license screen it just says "Loading license information..." forever.

Does anyone have any ideas? Websphere is still very new to me, so I'm sure I've made a simple mistake somewhere.

Ok, I've got more information from Websphere. I have a few runtime errors.

Exception occured during portlet registry reload! from com.ibm.isclite.service.portletregistry.PortletRegistryServiceImpl

-: java.lang.NoClassDefFoundError: $Proxy335 at sun.reflect.GeneratedMethodAccessor383.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:615) at com.ibm.team.repository.servlet.AbstractTeamServerServlet.doModelledRestService(AbstractTeamServerServlet.java:542) at com.ibm.team.repository.servlet.AbstractTeamServerServlet.service(AbstractTeamServerServlet.java:1434) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180) at org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90) at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:111) at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:75) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:115) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:966) at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:478) at com.ibm.ws.wswebcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:463) at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3107) at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:238) at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:811) at com.ibm.ws.wswebcontainer.WebContainer.handleRequest(WebContainer.java:1425) at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:92) at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:465) at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:394) at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:102) at com.ibm.ws.ssl.channel.impl.SSLReadServiceContext$SSLReadCompletedCallback.complete(SSLReadServiceContext.java:1812) at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:152) at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:213) at com.ibm.io.async.AbstractAsyncFuture.fireCompletionActions(AbstractAsyncFuture.java:195) at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:136) at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:193) at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:725) at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:847) at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1498) from com.ibm.ws.webcontainer.webapp.WebApp

SRVE0068E: Uncaught exception thrown in one of the service methods of the servlet: equinoxbridgeservlet. Exception thrown : java.lang.NoClassDefFoundError: $Proxy335 at sun.reflect.GeneratedMethodAccessor383.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:615) at com.ibm.team.repository.servlet.AbstractTeamServerServlet.doModelledRestService(AbstractTeamServerServlet.java:542) at com.ibm.team.repository.servlet.AbstractTeamServerServlet.service(AbstractTeamServerServlet.java:1434) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180) at org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90) at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:111) at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:75) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:115) at javax.servlet.http.HttpServlet.service(HttpServlet.java:856) at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:966) at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:478) at com.ibm.ws.wswebcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:463) at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3107) at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:238) at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:811) at com.ibm.ws.wswebcontainer.WebContainer.handleRequest(WebContainer.java:1425) at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:92) at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:465) at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:394) at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:102) at com.ibm.ws.ssl.channel.impl.SSLReadServiceContext$SSLReadCompletedCallback.complete(SSLReadServiceContext.java:1812) at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:152) at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:213) at com.ibm.io.async.AbstractAsyncFuture.fireCompletionActions(AbstractAsyncFuture.java:195) at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:136) at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:193) at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:725) at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:847) at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1498) from com.ibm.ws.webcontainer.servlet.ServletWrapper

5 answers



permanent link
derek cheng (46121) | answered Feb 04 '09, 10:16 a.m.
I'm not sure how I missed the exception message in the first post, but that exception points to you have having the latest WAS Java SDK fixpack installed. Can you double check that you have installed both the WAS and WAS Java SDK fixpacks?


Thanks Matt, that turned out to be the problem. When I used the fixpack wizard on ibm.com it didn't download the SDK update properly.

This is my first time with websphere, so I had no idea. Thanks very much for your help.

permanent link
Matt Lavin (2.7k2) | answered Feb 04 '09, 9:16 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
I'm not sure how I missed the exception message in the first post, but that exception points to you have having the latest WAS Java SDK fixpack installed. Can you double check that you have installed both the WAS and WAS Java SDK fixpacks?

permanent link
derek cheng (46121) | answered Feb 03 '09, 1:13 p.m.
Generally speaking, if you restart the server or jazz it works for at least a little while and then the license page stops working. It doesn't appear to affect creating work items or viewing other pages that I can see. It seems that anything non-license related continues to work.

This isn't a production environment though (that's still on tomcat for the time being).

Our jazz was a regular install including Tomcat. It's at E:\IBM\JazzTeamServer on a 64-bit windows 2003 server.


JVM Custom Properties
com.ibm.team.repository.provision.profile file:///E:/IBM/JazzTeamServer/server/provision_profiles
com.ibm.team.server.configURL file:///E:/IBM/JazzTeamServer/server/teamserver.properties
com.ibm.ws.console.runtime.events Warning
java.awt.headless true
log4j.configuration file:///E:/IBM/JazzTeamServer/server/log4j.properties
org.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin true


license-profile.ini
url=file:/E:/IBM/JazzTeamServer/server/license-update-site
featureid=com.ibm.team.rtc.server.license.standard-trial.feature
profile.ini
url=file:/E:/IBM/JazzTeamServer/server/update-site
featureid=com.ibm.team.rtc.server.feature


Screenshots of license pages while they are still working:
http://www.metron.mynuts.org/rtc/

permanent link
Matt Lavin (2.7k2) | answered Feb 03 '09, 9:38 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Ignoring the floating license install for a bit, can you use the server
for all other purposes? I'm trying to figure out if your problem is a
license install/setup problem or a WAS configuration problem.

-
Matt Lavin
Jazz Server Team


On Mon, 2009-02-02 at 14:48 +0000, derek wrote:
I'm having trouble with a fairly standard configuration of websphere.
We're using bluegroups, LDAP and websphere 6.1.

I've gotten almost everything working, but I'm still having two
issues.

  • Every user has to authentication
    twice. First at the /jazz URL and then at jazz/admin or jazz/web
    depending on their user type.
  • We have a floating license and are using a floating
    license server (localhost:9080). It worked fine when I first
    configured it, but now when you try to load up the license screen it
    just says "Loading license information..."
    forever.
    Does anyone have any ideas? Websphere is still very new to me, so I'm
    sure I've made a simple mistake somewhere.

  • permanent link
    derek cheng (46121) | answered Feb 03 '09, 8:44 a.m.
    I also get this message when I try to upload the server activation key.

    I'm not sure what's going on. It forgets the license and I can't seem to upload anything when that happens.

    Error uploading Server Activation key: The server is not responding; it may be unavailable...

    Your answer


    Register or to post your answer.


    Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.