It's all about the answers!

Ask a question

Install RTC client 4.0.1 to Eclipse(Juno/Kepler) fails.


Qunfeng Wang (421610) | asked Sep 10 '13, 4:11 a.m.
I'm trying to install RTC Client as an extension of my existing Eclipse. I tried both Juno and Kepler, all fails. It's quite frustrated. Why do you make the installer so hard?

RTC Client: 4.0.1
OS: Win 7 64bit
Eclipse: Juno/Kepler JEE edition.

Accepted answer


permanent link
Anders Truelsen (1622020) | answered Sep 10 '13, 4:21 a.m.
I've extended Juno with 4.0.1 a number of times using the p2repo.

These are my steps:

Extract the Eclipse release to c:\tools\eclipse

Extend Eclipse by adding a remote update site with the RTC p2repo from ...\RTC\4.0.1\RTC-Client-p2Repo-4.0.1.zip

When Eclipse has restarted shift to the Jazz Admin perspective


What do you do, and what happens?
Qunfeng Wang selected this answer as the correct answer

Comments
Qunfeng Wang commented Sep 10 '13, 4:36 a.m.

What is RTC p2repo?
Where is ...\RTC\4.0.1\RTC-Client-p2Repo-4.0.1.zip? Do I have to download it from somewhere?


Anders Truelsen commented Sep 10 '13, 5:18 a.m.

Hi Qunfeng



regards
/anders


Qunfeng Wang commented Sep 10 '13, 10:28 a.m.

Thanks. It works.

2 other answers



permanent link
Simon Eickel (1.1k75457) | answered Sep 10 '13, 4:31 a.m.
In addition to what Anders said:
make sure that your proxy configuration is set correctly and that you've marked "Contact all update sites during install to find required software":


This is needed cause the p2 packages has some dependencies to other plugins which may need to be updated or installed

Hope this helps,
Simon

permanent link
Takehiko Amano (1.3k3641) | answered Sep 10 '13, 4:29 a.m.
JAZZ DEVELOPER
Hi,

I'm afraid RTC V4.0.1 does not support Juno / Kepler as these are based on Eclipse V4. RTC V4.0.1 only supports V3.6 and 3.7.

 https://jazz.net/library/article/1109

Good news is that latest RTC support Eclipse V4.2.2 or above (though it is IES).

 https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements

Note that system requirement explicitly states about IES (IBM Eclipse SDK), depending on plug-ins you have on Juno/Kepler, it may not work due to conflicts between plug-ins or missing plug-ins.

By the way, I assume you use p2 install.








Comments
Qunfeng Wang commented Sep 10 '13, 4:34 a.m.

Thanks. I tried with Indigo, it still failed. The Eclipse complains about some missing packages.


Qunfeng Wang commented Sep 10 '13, 4:35 a.m.

By the way, what is p2 install? I just download a CLM-Web-Installer-Win-4.0.1.zip from jazz.net.


Takehiko Amano commented Sep 10 '13, 4:45 a.m.
JAZZ DEVELOPER

First of all, looks like there is some success to install RTC V4.0.1 on Juno, so it worth a try. Navigate to all downloads, and in the end of the page.

https://jazz.net/downloads/rational-team-concert/releases/4.0.1?p=allDownloads



Download this file. And then, install using this procedure.

https://jazz.net/help-dev/clm/topic/com.ibm.jazz.install.doc/topics/t_client_installation_p2.html

- Start Eclipse and select Help > Install New Software.

- In the Available Software window, click Add. In the Add Repository window, click Archive and navigate to the p2 Install Repository .zip file that you downloaded.


Qunfeng Wang commented Sep 10 '13, 10:28 a.m.

It works. But I think RTC has to fix its web installer.

Your answer


Register or to post your answer.