It's all about the answers!

Ask a question

4.0.3 Express setup fails

Juerg Brandenberger (1112) | asked Sep 06 '13, 9:19 a.m.
For the moment I do not need more than the express setup for a first contact with jts.
I tried on a virtual SLES 11 and as it did not work then on a Win 7-64 workstation. (correct versions of course!)
I think the prepared installation is very, very poor. After finding out SSL configuration for tomcat must be done manually, I did so, and now I can access tomcat over SSL.
Calling as told fails with 404 i.e. not found. No surprise, within the web context base directory I have no file which could by far correspond to any kind of setup. I have the web.xml, and 2 directories one called "eclipse", the other "lib". The content of those directories seems to me to be more eclipse related, than for a web application!
I tried setup from the commandline too. e.g. repotools-jts.bat -setup repositoryURL=https:// :8443/jts adminUserID= ADMIN adminPassword= ADMIN
But this doesen't help neither!
So I downloaded the zip file to have a look into it. But also in the zip I only do have the same mentioned content, so I guess no other result. What must I download to have a first look into JTS? The aim is to integrate my own SW into it for easy access and use.

One answer

permanent link
Bo Chulindra (1.3k2718) | answered Sep 06 '13, 11:02 a.m.
The default HTTPS port is 9443. I notice that you are using 8443.

The host name in the URLs you are using should be the host name of the machine your server is installed on. You mentioned and If these are not the actual host names of the machine your server is on, then it is not expected to work. Try localhost if you are using a browser or command line from the same machine that the server is on.

Make sure you have started the server first.

If the server is only a test server, you do not need to configure the SSL configuration. It has a self-signed certificate by default.

Juerg Brandenberger commented Sep 07 '13, 6:03 a.m.

Please don't take me for dumb!
1., means I use a qualified hostname. There is no need to publish it here.
2. If I'm using 8443 port, it is because it is configured on this port! Anyway even using the "express setup" tomcat is not configured it an usable way, so I'm free to set it up as I feel correct. 9xxx ports are normally used by WAS! I use 8xxx for Tomcat.
3. I said, I can access the tomcat over ssl, so If you had read my question, you could conclude, that the mentioned details works as it should!

I wonder why I have eclipse related files in my peployed server instead of a web application!

Your answer

Register or to post your answer.