It's all about the answers!

Ask a question

Why can't I create a build definition in rtc client?


Stefan Groß (1611) | asked Aug 29 '13, 5:33 a.m.
Hi guys,

as I am new to RTC i am struggeling with defining builds. But first my prerequisites:

I am running rtc 4.0.3. I installed only the jts and the ccm applications. I left qm and rm uninstalled.

After setting up a project area i tried to define a build as suggested. A right-click in the team artifacts on the builds node pops a context menu that only shows "Refresh" (see picture). So I am not able to create a new build definition. I tried to figure out what is wrong working through the online tutorials but found nothing helpful.

Context Menu

Am I missing a suitable license for my user account or did I forget to install some component? Does anyon have suggestions for me? By the way, i installed the 10 developers free license.

Thank You in advance for your answers.


Comments
Krzysztof Kaźmierczyk commented Aug 29 '13, 5:53 a.m.

Hi Stefan,
Are you able to see the definition in web ui?


Stefan Groß commented Aug 29 '13, 5:57 a.m.

I am only able to browse the definitions. The web-client looks like this:

But as there are no definitions yet i do not see anything.

Accepted answer


permanent link
Simon Eickel (1.1k75457) | answered Aug 29 '13, 6:14 a.m.
edited Aug 29 '13, 6:23 a.m.
Hi Stefan,

which client are you using?
Build definitions can only be applied by using the Eclipse client.

The Visual Studio client shows the behaviour you see (only refresh button when clicking on the Builds node).

This is the menu using the VS client:


And this is Eclipse:


The problem is that there are two different Teams developing the clients at IBM.
In future administrative things shall only be done using the Web UI ... but I think this is still future music.

Hope this helps,
Simon
Stefan Groß selected this answer as the correct answer

Comments
Stefan Groß commented Aug 29 '13, 7:39 a.m.

That's it! Who could have expected this behaviour.
Thanks a lot Simon.

One other answer



permanent link
Henning Sternkicker (40626) | answered Aug 29 '13, 5:42 a.m.
JAZZ DEVELOPER
Maybe you do not have the right permissions to create a build definition.
Normally all permissions are base on user roles. So have a look at the user you are using and what role the user has. If you than have a look into the project area administration (in the web interface, there you find the link on the right side of your Name on the right corner of the screen) -> Manage this project area. You will find a permissions tab on the administration side and under team configuratoin you will see the "Build" permissions. Be sure that for your role the permission to create and save a build definition is selected.

Hope that helps.

Comments
Stefan Groß commented Aug 29 '13, 5:54 a.m.

Thank you for your quick response!
As I am just evaluating RTC the user i am working with has all Repository Permissions (JazzAdmins,JazzDWAdmins,JazzUsers,JazzGuests as well as JazzProjectAdmins).
Maybe the JAzzGuests permission is the problem.

As Client Access License i am using "Rational Team Concert - Developer".
I changed the project area permissions to grant access to all operations for everyone.
Unfortunately this does not solve the issue.


Your answer


Register or to post your answer.