It's all about the answers!

Ask a question

Install BIRT on RTC Client

Fábio Castro (6311215) | asked Jul 30 '13, 10:21 p.m.
 I'm trying to install BIRT by ganymede (, but always after installation RTC client reboot and I can not open RTC more. Always I receive a error and the log below:

Please, how to fix it?

!SESSION 2013-07-30 23:08:18.007 -----------------------------------------------
java.fullversion=JRE 1.6.0 IBM J9 2.4 Windows 7 amd64-64 jvmwa6460sr11-20120801_118201 (JIT enabled, AOT enabled)
J9VM - 20120801_118201
JIT  - r9_20120608_24176ifx1
GC   - 20120516_AA
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=pt_BR
Framework arguments:  -product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product

!ENTRY org.eclipse.osgi 4 0 2013-07-30 23:08:22.700
!MESSAGE Application error
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(

!ENTRY org.eclipse.osgi 2 0 2013-07-30 23:08:22.797
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-07-30 23:08:22.798
!MESSAGE Bundle initial@reference:file:p2/cic.p2.cache.location/plugins/org.eclipse.ui.win32_3.2.100.v20080408-0800.jar/ [1417] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-07-30 23:08:22.798
!MESSAGE Bundle initial@reference:file:p2/cic.p2.cache.location/plugins/org.eclipse.ui.workbench.compatibility_3.2.0.I20080509-2000/ [1419] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2013-07-30 23:08:22.798
!MESSAGE Bundle initial@reference:file:p2/cic.p2.cache.location/plugins/org.eclipse.update.core.win32_3.2.100.v20080107.jar/ [1423] was not resolved.

Accepted answer

permanent link
anoop mc (74811191221) | answered Jul 31 '13, 6:21 a.m.

Open the RTC Eclipse Client

Go to Help > Install New Software and Click on Available Software Sites

From there you can give the site URL and install from web directly.

test conn

install BIRT

Other way is to Install the same Manually.

Once you identify the required version of BIRT compatible with your RTC version

Download and UnZIP



Fábio Castro selected this answer as the correct answer

3 other answers

permanent link
Fábio Castro (6311215) | answered Jul 31 '13, 9:38 a.m.
Thank you so much, the procedure by Intall new software with Galileo worked!!!

permanent link
Krzysztof Kaźmierczyk (7.4k374103) | answered Jul 31 '13, 3:04 a.m.
edited Jul 31 '13, 3:04 a.m.
Hi Fabio,
What about installing RTC on Top of Eclipse with BIRT preinstalled? You can download Eclipse with BIRT installed from

Anyway if you want to install RTC on top of that, only RTC version 1 will work (which is out of support). What is your RTC version you are trying to use?

Hope it helps for you.

Best regards,
Krzysztof Kazmierczyk

Fábio Castro commented Jul 31 '13, 9:36 a.m.

My RTC Version is 4.2, I have just RTC Client installed.

permanent link
Indradri Basu (1.8k1514) | answered Jul 31 '13, 1:10 a.m.
To me this looks like it could be platform version mismatch for the Birt plugin. So for eclipse 3.5 it is Galileo, for 3.6 it is Helios, for 4.2 it is Juno and I suppose Ganymede works with 3.4.
Could you please confirm your eclipse version or the version of the RTC client you have installed.

Fábio Castro commented Jul 31 '13, 9:35 a.m.

 My RTC Client version is 4.2, I installed the Galileo and my RTC Client worked, I do not know if I will have problems to publicate it on Server.
Do you know the link of Juno?

Indradri Basu commented Jul 31 '13, 10:50 a.m.

Juno -

NOTE: I haven't tried this version of Birt myself and I am not aware if the existing or out of the box reports are compatible with it or have any implications.
I would suggest you to install the 3.6 eclipse client and use Helios which should be already listed under available site and follow the process which Anoop has mentioned.
However, I think many might be interested to know your findings(including me) should you choose to go ahead with the Juno release.

Fábio Castro commented Jul 31 '13, 1:45 p.m.

I tried to install Juno, but some required itens was not found like it:
  BIRT Install Error

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.