It's all about the answers!

Ask a question

RTC Error: items with a protected read access must use a public content id

jeanie Keen (132023) | asked Jun 10 '13, 1:58 p.m.

i did not realize the configuration of requiring a work item and comments was not turned on.

I created several txt files on the web that were not associated with a work item and also did not include the comment.  Then i found where to set the configuration and now noone can add a file without a comment or a work item.  Now i want to remove the junk test files i added. 

I selected the file > Remove

When i do this i am recieving the error:  items with a protected read access must use a public content id, a project id, or a current contributor id but the id "XXXXX" was used.

Any ideas on how to resolve this?

One answer

permanent link
Geoffrey Clemm (30.1k33035) | answered Jun 10 '13, 2:16 p.m.
The easiest workaround would be to use a different client (e.g. Eclipse, command line) to delete the file.
But it still would be interesting to know what was going wrong in the WebUI.

jeanie Keen commented Jun 10 '13, 5:04 p.m.

i figured it out

I had changed the acl to no one except administrators.  I changed it back to using project hiearchy and added team member role.  I did not realize i needed to have team member if i was the administrator i would assume that it should over ride everything.  After validating this worked i put the ACL back to the No one except administrators and it worked.  So ultimately was i needed to be a team member.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.