It's all about the answers!

Ask a question

the attribute "duration" return "undefined" error on 4.0.2 browser

chen fengmiao (7032932) | asked May 08 '13, 10:13 p.m.


   My RTC Server is 3.0.1 version.I upgrade to 4.0.2 version.But I find this question:the attribute "duration" in the workitem return "undefined" on browser


but this question didn't appear on the 3.0.1 version and 4.0.2 eclipse client, only appear 4.0.2 browser .

can you help me? thank you!

Krzysztof Kaźmierczyk commented May 09 '13, 2:18 a.m.

Hi Chen,
I believe that we need a bit more information:
1. Are you using any out of the box project template or you have customized one?
2. Are you using template sharing?
3. Does it happen for only one or more than one project areas? What is the difference between project areas which have the issue and which do not have it?

chen fengmiao commented May 09 '13, 5:01 a.m.

1. I using the formal  project template.

2. I using templdate sharing.

3. It happen only one project area,other project area didn't happen use formal project template.

Piotr Aniola commented May 09 '13, 5:54 a.m.

Can you also tell us what browser are you using?
What exactly are you doing when the issue occurs? Updating the WI? Displaying it?
Can you complete this activity in the Eclipse client?

chen fengmiao commented May 09 '13, 7:35 a.m.

1. I use firefox 12 ,firefox 8 and IE 8 ,they also appear the same error.

2. I only click this attribute 's input box ,nothing to do.

3. The issue didn't occurs in the Eclipse client.The attribute dispaly right.

chen fengmiao commented May 09 '13, 7:48 a.m.

the server export ccm.log:

2013-05-09 19:44:20,060 [         http-bio-9443-exec-75] ERROR                     - Problems serving sprite image service request
java.lang.IllegalArgumentException: Width (0) and height (0) cannot be <= 0
 at java.awt.image.DirectColorModel.createCompatibleWritableRaster(

Piotr Aniola commented May 09 '13, 10:48 a.m.

chen fengmiao commented May 09 '13, 11:01 a.m.

I don't open this workitem.I haven't  limits of authority. Can you tell me the default what say.If it fixed in 4.0.01.but It appear in 4.0.2

showing 5 of 7 show 2 more comments

2 answers

permanent link
Stephanie Bagot (2.1k1513) | answered May 22 '13, 11:42 p.m.
When you select the 'Duration' attribute, does it create multiple drop-downs per your screenshot? If so, you should be able to run a firebug trace and check the Console tab for errors. I have seen a similar issue with a client's custom process template where they removed an iteration (the Backlog iteration) and this caused the bad behaviour in the web UI and not in eclipse (same as you are seeing). The reason why it occurs in the web UI and not eclipse is because we call different code for the clients.

Once you check the console tab, it should tell you if there is a plan missing. The error may be a bit hard to decipher, so if you need additional help I would recommend you open up a PMR with IBM Support and include your process template as well as the firebug output.

chen fengmiao commented May 28 '13, 7:42 a.m.

thank you ,this error already solved.I removed a attribute that type is "contributor List" from "Attribute Mapping" in the "Plan Attributes": 

permanent link
Peterson dos Santos (3928) | answered Jun 08 '22, 1:32 p.m.
Hi my friends,

Thank you for share the solution!
I do the same here and everthing ok!


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.