It's all about the answers!

Ask a question

"could not create the java virtual machine" when install Eclipse 4.0.1 IDE

Don Yang (7.7k21114139) | asked Apr 24 '13, 4:01 a.m.
We have 10+ Win 7 32bit (4.0GB memory) machines and want to install VS client IDE(for 2010) or Eclipse 4.0.1 client. We have two machines got problem. On both problematic machines, MyEclipse 9.0 was installed and removed(no entry in class path and no existing folders related to myeclipse), machine restarted and then thick clients are installed.

On one machine, when install Eclipse client 401, we see it throw "could not create the java virtual machine"  in 70-80% progress and install failed.
On another machine, we installed VS2010 client IDE and no problem in installation. But when creating repository connection, it throws:

ScmUI: Unable to register the event listener  start SCM program on _no_cfaE:\Digital\IBM\Rational Team Concert Client for Microsoft Visual Studio IDE\3rd Party\scmtools\eclipse\scm.exeError in thread "main" java/lang/Error: bootstrap error, system property access before init:


JVMJ9VM015W Initialization error for library jclscar_24(14): JVMJ9VM009E J9VMDllMain failed
Failed to create the Java Virtual Machine.
This seems to us it's the same cause as Eclipse install error.

Since the machine both had MyEclipse installed(uninstalled now)previously, I suspect this could be related as all other machines have no problem.
My questions are:

1) In VS 2010, is there any place for us to specify the JVM similar I can specify in Eclipse.ini file?
2) It seems that MyEclipse is causing the problem. How do we clean uninstall MyEclipse so that it won't affect Eclipse client IDE install? Or is there any way for us to workaround the install error so that we can try to specify other JVM in eclipse.ini afterwards?
Thank you very much for any inputs.

Accepted answer

permanent link
John Kim (36) | answered May 20 '13, 11:02 p.m.
Hi Dong,

The same error has recently been identified as an IBM JVM defect.

Cause: Invalid UTF-8 input makes the Java VM to access system properties before fully initialized that results in exception.
This defect will be fixed in: 6.0.0 SR14, 6.0.1 SR6, 7.0.0 SR5.
For the details, please take a look at

As a quick verification, you may launch Eclipse client 401 by pointing other JVM (i.e. alter -vm section in the eclipse.ini ) installed in the machine.

Hope it helps.
Don Yang selected this answer as the correct answer

Don Yang commented May 20 '13, 11:14 p.m.

Thanks John. I have passed this info to the user to have a try now.

Don Yang commented Sep 02 '13, 1:21 a.m.

If you can use plain zip Eclipse client, then there is eclipse.ini file for you. Otherwise, if you want to try with Installation Manager, you may try to go to Installation Manager's installed dir\eclipse\IBMIM.ini file and then point the -vm to other JRE and try again.

4 other answers

permanent link
Krzysztof Kaźmierczyk (7.5k478103) | answered Apr 24 '13, 4:20 a.m.
Hello Dong,
Your issue regarding Initialization error is known issue:
You need to check your JAVA_HOME variable and what java is included in PATH variable. You can change your java in eclipse.ini file: (this last tip indicates at least for Eclipse issue)
Could you also let us know at which stage of installation you have this error?
Also as a work around you can try out of the box RTC version: let us know if it works for you.

Let us know if any of these tips helped you.

Don Yang commented Apr 24 '13, 11:58 p.m.

Thanks for the info.

There is no Java_home variable available(see another comment with the env info in PATH). Since the install fails at 70-80% install when there is no eclipse.ini created yet, I don't think we can point JVM to another JRE/JDK. We are installing and it fails. Are we able to install Sun JDK/JRE6.0 Update 23+ and then create JAVA_HOME and point to the Sun JRE Path and then try to install again? It puzzles me why it complains JVM issue as the install is not completed yet. Does that mean Install also need JVM? If yes, which file can we check with(so that we can point to other JRE/JDK)?

Krzysztof Kaźmierczyk commented Apr 25 '13, 2:31 a.m.

IBM Installation Manager which you are using to install Eclipse is also Eclipse (java) based application. Moreover it might run another Java processes during work.

permanent link
Karl Weinert (2.0k52736) | answered Apr 26 '13, 1:52 p.m.
I found this technote

It isn't a problem installing eclipse but it is related to using installation manager.
Here's the workaround from that document:


If your machine can allocate more than 512MB of continuous heap space, here is one workaround that can allow install/update to complete:

  1. Start Command Prompt (Start > Run type cmd )
  2. Change directory to where Installation Manager is installed.
    For example,  C:\Program Files\IBM\Installation Manager\eclipse
  3. Start Installation Manager using this command:
    IBMIM.exe -vmargs -Dcic.doNotInitialize=true -Xquickstart -Xgcpolicy:gencon
  4. Install/update product as usual
  • This will install/update product normally.
  • The main difference is that it will skip eclipse initialization.
  • Because of that, the first startup of the product will take longer.
  • Should not have functional impact.
  • With this change, you can update eclipse.ini manually after the install/update to update -Xmx option to workaround the memory issue.

Don Yang commented Apr 28 '13, 10:04 p.m.

Thanks All for the suggestions and info.

permanent link
Rene Meyer (42913334) | answered Apr 24 '13, 4:09 a.m.
my guess is, that some global or user specific environment variables are set, which are picked up by the RTC JVM.
Some tools set global Options like JDK Home, bootclasspath option, JAVA_OPTIONS.
When you dump the environment variables with set on the command line window it should be visible.
Best Regards,

Don Yang commented Apr 24 '13, 11:54 p.m.

Thanks for the suggestion.
The env info does not seem to have much info related to JDK except F:\StudySoftware\JDK\bin.
What I dont understand is why Eclipse install failure when referring to JVM in the log which was not installed yet(only P2 and Configuration folders are seen when the error pops up.
C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;F:\StudySoftware\JDK\bin;F:\StudySoftware\Rose\common;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files\Windows Kits\8.0\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\

Don Yang commented Apr 25 '13, 2:25 a.m.

When uninstalling VSclient 4.0.1 and install 4.0.0 VS client, creating repository connection works. I don't really know what happens and how to get VS401 work for 401 server even though VS4.0 client is compatible with 401 server. Installing Eclipse 4.0.1 client still have problem..

permanent link
Don Yang (7.7k21114139) | answered Apr 24 '13, 4:17 a.m.
Thanks for the prompt suggestions. will have a check.
BTW, the log shows in Eclipse install as below. It seems to have the same error as in VS
JVMJ9VM015W Initialization error for library jclscar_24(14): JVMJ9VM009E J9VMDllMain failed
It seems to points to Eclipse's own: C:\Program Files\IBM\TeamConcert\jdk\jre\bin\javaw.exe
not sure why it does not work
 <message>C:\Program Files\IBM\TeamConcert\eclipse.exe -application org.eclipse.equinox.p2.reconciler.application -product org.eclipse.equinox.p2.reconciler.dropins.product -nosplash --launcher.suppressErrors -vmargs -Xms100m -Xmx512m -Dosgi.requiredJavaVersion=1.5 -Dosgi.bundlefile.limit=100 -Dorg.eclipse.equinox.simpleconfigurator.exclusiveInstallation=false\Program Files\IBM\TeamConcert\configuration\org.eclipse.update\ -Declipse.p2.verifyPlan=false
<entry num='133' time='1366789983390' elapsed='09:42.45' level='ERROR' thread='Worker-1'>
  <key>Eclipse p2 协调程序:{0}
  <arg>线程 "main" 中发生异常java/lang/Error: bootstrap error, system property access before init:
    位于 java/lang/System.getProperty(
    位于 java/lang/System.getProperty(
    位于 java/lang/Boolean.getBoolean(
    位于 sun/security/action/
    位于 sun/security/action/
    位于 java/security/AccessController.doPrivileged(
    位于 com/ibm/misc/IOConverter.toIgnoreMalformedInput(
    位于 com/ibm/misc/IOConverter.convert(
    位于 java/lang/StringCoding.decode(
    位于 java/lang/String.&lt;init&gt;(
    位于 com/ibm/oti/util/Util.toString(
    位于 java/lang/System.getPropertyList(本机方法)
    位于 java/lang/System.ensureProperties(
    位于 java/lang/System.afterClinitInitialization(
    位于 java/lang/Thread.initialize(
    位于 java/lang/Thread.&lt;init&gt;(
JVMJ9VM015W 在库 jclscar_24(14) 中发生初始化错误 JVMJ9VM009E J9VMDllMain 失败
Java was started but returned exit code=1
C:\Program Files\IBM\TeamConcert\jdk\jre\bin\javaw.exe
-Dorg.eclipse.equinox.simpleconfigurator.exclusiveInstallation=false\Program Files\IBM\TeamConcert\configuration\org.eclipse.update\
-jar C:\Program Files\IBM\TeamConcert\\plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-os win32
-ws win32
-arch x86
-launcher C:\Program Files\IBM\TeamConcert\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\IBM\TeamConcert\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.2.R36x_v20101222\eclipse_1312.dll
-startup C:\Program Files\IBM\TeamConcert\\plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-exitdata 870_50
-install C:\Program Files\IBM\TeamConcert
-application org.eclipse.equinox.p2.reconciler.application
-product org.eclipse.equinox.p2.reconciler.dropins.product
-vm C:\Program Files\IBM\TeamConcert\jdk\jre\bin\javaw.exe
-Dorg.eclipse.equinox.simpleconfigurator.exclusiveInstallation=false\Program Files\IBM\TeamConcert\configuration\org.eclipse.update\
-jar C:\Program Files\IBM\TeamConcert\\plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.